summaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/glogg/glogg.SlackBuild4
-rw-r--r--misc/glogg/glogg.info8
-rw-r--r--misc/gourmet/gourmet.SlackBuild5
-rw-r--r--misc/gourmet/gourmet.info2
-rw-r--r--misc/gourmet/slack-desc2
-rw-r--r--misc/gourmet/tostring-to-tobytes.patch26
-rw-r--r--misc/ibus-unikey/ibus-unikey.SlackBuild2
-rw-r--r--misc/krename/krename.SlackBuild3
-rw-r--r--misc/krename/null.patch12
-rw-r--r--misc/stardict-tools/stardict-tools.SlackBuild3
-rw-r--r--misc/xca/xca.SlackBuild4
-rw-r--r--misc/yapet/gcc6.patch11
-rw-r--r--misc/yapet/yapet.SlackBuild3
-rw-r--r--misc/zinnia/zinnia-fixes-gcc6-compile.patch22
-rw-r--r--misc/zinnia/zinnia.SlackBuild3
15 files changed, 100 insertions, 10 deletions
diff --git a/misc/glogg/glogg.SlackBuild b/misc/glogg/glogg.SlackBuild
index 0278e2c4e8..33c808c379 100644
--- a/misc/glogg/glogg.SlackBuild
+++ b/misc/glogg/glogg.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=glogg
-VERSION=${VERSION:-1.0.2}
+VERSION=${VERSION:-1.1.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,7 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-qmake
+qmake-qt5
make
make install INSTALL_ROOT=$PKG/usr
diff --git a/misc/glogg/glogg.info b/misc/glogg/glogg.info
index 61587350f7..fb8c11dd71 100644
--- a/misc/glogg/glogg.info
+++ b/misc/glogg/glogg.info
@@ -1,10 +1,10 @@
PRGNAM="glogg"
-VERSION="1.0.2"
+VERSION="1.1.4"
HOMEPAGE="http://glogg.bonnefon.org/"
-DOWNLOAD="http://glogg.bonnefon.org/files/glogg-1.0.2.tar.gz"
-MD5SUM="d6d9bb70ed50a38c5fa9114d71b52d3d"
+DOWNLOAD="http://glogg.bonnefon.org/files/glogg-1.1.4.tar.gz"
+MD5SUM="065d292411df490dcb3c6abae35ed608"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="qt5"
MAINTAINER="Miroslaw Turski"
EMAIL="miroslaw.turski@gmail.com"
diff --git a/misc/gourmet/gourmet.SlackBuild b/misc/gourmet/gourmet.SlackBuild
index e9a2f0f93d..0121943095 100644
--- a/misc/gourmet/gourmet.SlackBuild
+++ b/misc/gourmet/gourmet.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=gourmet
VERSION=${VERSION:-0.17.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,6 +69,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Patch to replace removed tostring() with tobytes()
+patch -p1 < $CWD/tostring-to-tobytes.patch
+
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/misc/gourmet/gourmet.info b/misc/gourmet/gourmet.info
index 16bbef1a65..64f0f25902 100644
--- a/misc/gourmet/gourmet.info
+++ b/misc/gourmet/gourmet.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/thinkle/gourmet/archive/0.17.4.tar.gz"
MD5SUM="937334364abc3093709a604c1d473e9f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="SQLAlchemy python-distutils-extra reportlab pygtkspell gst0-python python-elib.intl"
+REQUIRES="SQLAlchemy lxml python-distutils-extra reportlab pygtkspell gst0-python python-elib.intl pypoppler"
MAINTAINER="Erwin van Zanten"
EMAIL="e.van.zanten.evz@gmail.com"
diff --git a/misc/gourmet/slack-desc b/misc/gourmet/slack-desc
index 16eb4722a4..ae51c1b38c 100644
--- a/misc/gourmet/slack-desc
+++ b/misc/gourmet/slack-desc
@@ -6,7 +6,7 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-gourmet: gourmet (A Recipe organizer for Linux)
+gourmet: Gourmet (a recipe organizer for Linux)
gourmet:
gourmet: Gourmet Recipe Manager is a recipe-organizer that allows you
gourmet: to collect, search, organize, and browse your recipes.
diff --git a/misc/gourmet/tostring-to-tobytes.patch b/misc/gourmet/tostring-to-tobytes.patch
new file mode 100644
index 0000000000..e42c59403d
--- /dev/null
+++ b/misc/gourmet/tostring-to-tobytes.patch
@@ -0,0 +1,26 @@
+diff --git a/gourmet/gtk_extras/ratingWidget.py b/gourmet/gtk_extras/ratingWidget.py
+index 0e01735..efa6463 100644
+--- a/gourmet/gtk_extras/ratingWidget.py
++++ b/gourmet/gtk_extras/ratingWidget.py
+@@ -135,7 +135,7 @@ class StarGenerator:
+ if is_rgba: rowstride = 4
+ else: rowstride = 3
+ pb=gtk.gdk.pixbuf_new_from_data(
+- image.tostring(),
++ image.tobytes(),
+ gtk.gdk.COLORSPACE_RGB,
+ is_rgba,
+ 8,
+diff --git a/gourmet/plugins/browse_recipes/icon_helpers.py b/gourmet/plugins/browse_recipes/icon_helpers.py
+index 61c772c..2e7b08b 100644
+--- a/gourmet/plugins/browse_recipes/icon_helpers.py
++++ b/gourmet/plugins/browse_recipes/icon_helpers.py
+@@ -38,7 +38,7 @@ def get_pixbuf_from_image (image):
+ if is_rgba: rowstride = 4
+ else: rowstride = 3
+ pb=gtk.gdk.pixbuf_new_from_data(
+- image.tostring(),
++ image.tobytes(),
+ gtk.gdk.COLORSPACE_RGB,
+ is_rgba,
+ 8,
diff --git a/misc/ibus-unikey/ibus-unikey.SlackBuild b/misc/ibus-unikey/ibus-unikey.SlackBuild
index 3e2c7cc047..26ac340db0 100644
--- a/misc/ibus-unikey/ibus-unikey.SlackBuild
+++ b/misc/ibus-unikey/ibus-unikey.SlackBuild
@@ -60,7 +60,7 @@ patch -p1 -i $CWD/gcc-6.diff
./autogen.sh
CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS -Wno-error=narrowing" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
diff --git a/misc/krename/krename.SlackBuild b/misc/krename/krename.SlackBuild
index f084711cd4..4e67905635 100644
--- a/misc/krename/krename.SlackBuild
+++ b/misc/krename/krename.SlackBuild
@@ -71,6 +71,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Fix for gcc >= 6.x
+patch -p1 < $CWD/null.patch
+
KDEPREF=$(kde4-config --prefix)
cmake \
diff --git a/misc/krename/null.patch b/misc/krename/null.patch
new file mode 100644
index 0000000000..991ebbea1c
--- /dev/null
+++ b/misc/krename/null.patch
@@ -0,0 +1,12 @@
+diff -Naur krename-r247.orig/src/batchrenamer.cpp krename-r247/src/batchrenamer.cpp
+--- krename-r247.orig/src/batchrenamer.cpp 2013-11-24 22:46:05.000000000 +0100
++++ krename-r247/src/batchrenamer.cpp 2017-06-20 14:42:57.330437870 +0200
+@@ -402,7 +402,7 @@
+ break;
+ case eRenameMode_Link:
+ // In case of link delete created file
+- job = KIO::file_delete( dstUrl, false );
++ job = KIO::file_delete( dstUrl, NULL );
+ break;
+ case eRenameMode_Copy: // no undo possible
+ // TODO: Maybe we should delete the created files
diff --git a/misc/stardict-tools/stardict-tools.SlackBuild b/misc/stardict-tools/stardict-tools.SlackBuild
index 7a681ee867..5466bff3f4 100644
--- a/misc/stardict-tools/stardict-tools.SlackBuild
+++ b/misc/stardict-tools/stardict-tools.SlackBuild
@@ -52,6 +52,9 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p0 < $CWD/stardict-tools.patch
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS -Wno-error=narrowing -fpermissive" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
diff --git a/misc/xca/xca.SlackBuild b/misc/xca/xca.SlackBuild
index 667eb50d9f..903a101f97 100644
--- a/misc/xca/xca.SlackBuild
+++ b/misc/xca/xca.SlackBuild
@@ -69,6 +69,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Hack to avoid building the html docs, broken with the newer linuxdoc-tools
+sed -i '/case "$DOCTOOL" in/i \
+DOCTOOL=true' configure
+
sed -i \
-e 's/LIBS="\${LIBS} \${OPENSSL_LIBS}\${QT_LIBS}"/LIBS="\${LIBS} \${OPENSSL_LIBS} \${QT_LIBS}"/' \
configure
diff --git a/misc/yapet/gcc6.patch b/misc/yapet/gcc6.patch
new file mode 100644
index 0000000000..a57e0c93c1
--- /dev/null
+++ b/misc/yapet/gcc6.patch
@@ -0,0 +1,11 @@
+--- yapet-1.0/yapet/cfg.h 2014-02-23 10:18:41.000000000 -0700
++++ yapet-1.0/yapet/cfg.h 2016-04-14 07:06:49.665672169 -0700
+@@ -163,7 +163,7 @@
+ locked = false;
+ }
+
+- void is_locked() const {
++ bool is_locked() const {
+ return locked;
+ }
+
diff --git a/misc/yapet/yapet.SlackBuild b/misc/yapet/yapet.SlackBuild
index 25630ffe46..91af2b8d91 100644
--- a/misc/yapet/yapet.SlackBuild
+++ b/misc/yapet/yapet.SlackBuild
@@ -69,6 +69,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# From upstream
+patch -p1 < $CWD/gcc6.patch
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
diff --git a/misc/zinnia/zinnia-fixes-gcc6-compile.patch b/misc/zinnia/zinnia-fixes-gcc6-compile.patch
new file mode 100644
index 0000000000..848f306edb
--- /dev/null
+++ b/misc/zinnia/zinnia-fixes-gcc6-compile.patch
@@ -0,0 +1,22 @@
+Index: zinnia-0.06/trainer.cpp
+===================================================================
+--- zinnia-0.06.orig/trainer.cpp
++++ zinnia-0.06/trainer.cpp
+@@ -93,7 +93,7 @@ class TrainerImpl: public Trainer {
+
+ public:
+ bool add(const Character &character) {
+- const std::string y = character.value();
++ std::string y = character.value();
+ CHECK_FALSE(!y.empty()) << "input character is empty";
+ Features features;
+ CHECK_FALSE(features.read(character)) << "cannot read character: " << y;
+@@ -103,7 +103,7 @@ class TrainerImpl: public Trainer {
+ if (!fn) {
+ return false;
+ }
+- x_.push_back(std::make_pair<std::string, FeatureNode *>(y, fn));
++ x_.push_back(std::make_pair(y, fn));
+ return true;
+ }
+
diff --git a/misc/zinnia/zinnia.SlackBuild b/misc/zinnia/zinnia.SlackBuild
index efd04acd51..62b3c033e4 100644
--- a/misc/zinnia/zinnia.SlackBuild
+++ b/misc/zinnia/zinnia.SlackBuild
@@ -70,6 +70,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Thanks to fedora for this patch
+patch -p1 < $CWD/zinnia-fixes-gcc6-compile.patch
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \