summaryrefslogtreecommitdiffstats
path: root/libraries/zope.location/zope.location.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/zope.location/zope.location.SlackBuild')
-rw-r--r--libraries/zope.location/zope.location.SlackBuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/libraries/zope.location/zope.location.SlackBuild b/libraries/zope.location/zope.location.SlackBuild
index 2c22691c09..76a9056c2a 100644
--- a/libraries/zope.location/zope.location.SlackBuild
+++ b/libraries/zope.location/zope.location.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for zope.location
# Copyright 2014 Mikko Värri, Finland
+# Copyright 2023 Yth | Pont-en-Royans, France | yth@ythogtha.org
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=zope.location
-VERSION=${VERSION:-4.0.3}
+VERSION=${VERSION:-5.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -60,15 +61,18 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYRIGHT.txt LICENSE.txt CHANGES.rst README.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.rst COPYRIGHT.txt LICENSE.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install