summaryrefslogtreecommitdiffstats
path: root/libraries/zope.event/zope.event.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/zope.event/zope.event.SlackBuild')
-rw-r--r--libraries/zope.event/zope.event.SlackBuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/libraries/zope.event/zope.event.SlackBuild b/libraries/zope.event/zope.event.SlackBuild
index fd389e558b..4930c54492 100644
--- a/libraries/zope.event/zope.event.SlackBuild
+++ b/libraries/zope.event/zope.event.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for zope.event
# Copyright 2013 Mikko Värri, Finland
+# Copyright 2023 Yth | Pont-en-Royans, France | yth@ythogtha.org
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=zope.event
-VERSION=${VERSION:-4.0.3}
+VERSION=${VERSION:-5.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -60,17 +61,15 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGES.rst COPYRIGHT.txt LICENSE.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION