summaryrefslogtreecommitdiffstats
path: root/libraries/zope.component
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/zope.component')
-rw-r--r--libraries/zope.component/zope.component.SlackBuild19
-rw-r--r--libraries/zope.component/zope.component.info12
2 files changed, 15 insertions, 16 deletions
diff --git a/libraries/zope.component/zope.component.SlackBuild b/libraries/zope.component/zope.component.SlackBuild
index 1039c57989..bc320255d1 100644
--- a/libraries/zope.component/zope.component.SlackBuild
+++ b/libraries/zope.component/zope.component.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for zope.component
# Copyright 2014 Mikko Värri, Finland
+# Copyright 2023 Yth | Pont-en-Royans, France | yth@ythogtha.org
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=zope.component
-VERSION=${VERSION:-4.2.1}
+VERSION=${VERSION:-6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -60,17 +61,15 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGES.rst COPYRIGHT.txt LICENSE.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/libraries/zope.component/zope.component.info b/libraries/zope.component/zope.component.info
index 7cd8c14d8e..5593db33c3 100644
--- a/libraries/zope.component/zope.component.info
+++ b/libraries/zope.component/zope.component.info
@@ -1,10 +1,10 @@
PRGNAM="zope.component"
-VERSION="4.2.1"
+VERSION="6.0"
HOMEPAGE="https://pypi.python.org/pypi/zope.component/"
-DOWNLOAD="https://pypi.python.org/packages/source/z/zope.component/zope.component-4.2.1.tar.gz"
-MD5SUM="cf55d496428d976f9329a4a2330a8b54"
+DOWNLOAD="https://pypi.python.org/packages/source/z/zope.component/zope.component-6.0.tar.gz"
+MD5SUM="55d4d24f425b18e2368a18c468f8cc47"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="zope.event zope.interface"
-MAINTAINER="Mikko Värri"
-EMAIL="vmj@linuxbox.fi"
+REQUIRES="zope.event zope.hookable zope.interface"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"