summaryrefslogtreecommitdiffstats
path: root/libraries/zc.lockfile
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/zc.lockfile')
-rw-r--r--libraries/zc.lockfile/README2
-rw-r--r--libraries/zc.lockfile/slack-desc19
-rw-r--r--libraries/zc.lockfile/zc.lockfile.SlackBuild78
-rw-r--r--libraries/zc.lockfile/zc.lockfile.info10
4 files changed, 0 insertions, 109 deletions
diff --git a/libraries/zc.lockfile/README b/libraries/zc.lockfile/README
deleted file mode 100644
index 1203ec6791..0000000000
--- a/libraries/zc.lockfile/README
+++ /dev/null
@@ -1,2 +0,0 @@
-The zc.lockfile package provides a basic portable implementation of
-interprocess locks using lock files.
diff --git a/libraries/zc.lockfile/slack-desc b/libraries/zc.lockfile/slack-desc
deleted file mode 100644
index ccbb67ba47..0000000000
--- a/libraries/zc.lockfile/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-zc.lockfile: zc.lockfile (Basic inter-process locks)
-zc.lockfile:
-zc.lockfile: The zc.lockfile package provides a basic portable implementation of
-zc.lockfile: interprocess locks using lock files.
-zc.lockfile:
-zc.lockfile:
-zc.lockfile:
-zc.lockfile:
-zc.lockfile:
-zc.lockfile:
-zc.lockfile:
diff --git a/libraries/zc.lockfile/zc.lockfile.SlackBuild b/libraries/zc.lockfile/zc.lockfile.SlackBuild
deleted file mode 100644
index 70320a52bd..0000000000
--- a/libraries/zc.lockfile/zc.lockfile.SlackBuild
+++ /dev/null
@@ -1,78 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for zc.lockfile
-
-# Copyright 2013 Mikko Värri, Finland
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=zc.lockfile
-VERSION=${VERSION:-1.1.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-unzip $CWD/$PRGNAM-$VERSION.zip
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYRIGHT.txt LICENSE.txt README.txt PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/zc.lockfile/zc.lockfile.info b/libraries/zc.lockfile/zc.lockfile.info
deleted file mode 100644
index 13177c72ec..0000000000
--- a/libraries/zc.lockfile/zc.lockfile.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="zc.lockfile"
-VERSION="1.1.0"
-HOMEPAGE="https://pypi.python.org/pypi/zc.lockfile"
-DOWNLOAD="https://pypi.python.org/packages/source/z/zc.lockfile/zc.lockfile-1.1.0.zip"
-MD5SUM="8e46b830417363501363bd09e1af1ecc"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Mikko Värri"
-EMAIL="vmj@linuxbox.fi"