summaryrefslogtreecommitdiffstats
path: root/libraries/wxPython3/wxPython3.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/wxPython3/wxPython3.SlackBuild')
-rw-r--r--libraries/wxPython3/wxPython3.SlackBuild28
1 files changed, 0 insertions, 28 deletions
diff --git a/libraries/wxPython3/wxPython3.SlackBuild b/libraries/wxPython3/wxPython3.SlackBuild
index 9d939a0002..b9fe787df5 100644
--- a/libraries/wxPython3/wxPython3.SlackBuild
+++ b/libraries/wxPython3/wxPython3.SlackBuild
@@ -89,30 +89,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --disable-static \
- --with-gtk=3 \
- --with-sdl \
- --with-opengl \
- --enable-unicode \
- --enable-graphics_ctx \
- --enable-display \
- --enable-mediactrl \
- --enable-graphics_ctx \
- --enable-sound \
- --disable-precomp-headers \
- --with-wx-config=/usr/bin/wx-config \
- --libdir=/usr/lib$LIBDIRSUFFIX \
- --build=$ARCH-slackware-linux \
- $wx
-
-make
-
cd wxPython
python2 setup.py \
WXPORT=gtk3 \
@@ -143,10 +119,6 @@ cd wxPython
rm -rf $PKG/usr/lib$LIBDIRSUFFIX/python2.7/site-packages/wx-3.0-gtk2/wx/tools/Editra
cd -
-# install wxPython includes
-mkdir -p $PKG/usr/include/wx-3.0/wx/
-cp -rf wxPython/include/wx/wxPython $PKG/usr/include/wx-3.0/wx/
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true