summaryrefslogtreecommitdiffstats
path: root/libraries/webkit2gtk
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/webkit2gtk')
-rw-r--r--libraries/webkit2gtk/webkit2gtk.SlackBuild16
-rw-r--r--libraries/webkit2gtk/webkit2gtk.info8
2 files changed, 15 insertions, 9 deletions
diff --git a/libraries/webkit2gtk/webkit2gtk.SlackBuild b/libraries/webkit2gtk/webkit2gtk.SlackBuild
index d54d9bfc36..44b052fc42 100644
--- a/libraries/webkit2gtk/webkit2gtk.SlackBuild
+++ b/libraries/webkit2gtk/webkit2gtk.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=webkit2gtk
SRCNAM=webkitgtk
-VERSION=${VERSION:-2.20.5}
+VERSION=${VERSION:-2.30.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -74,16 +74,22 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# ensure backward compatibility with the latest version of icu:
+# http://linuxfromscratch.org/blfs/view/svn/x/webkitgtk.html
+echo 'add_compile_definitions("U_DEFINE_FALSE_AND_TRUE=1")' >> Source/WTF/wtf/CMakeLists.txt
+
mkdir -p build
cd build
cmake -DPORT=GTK \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_SKIP_RPATH=ON \
+ -DCMAKE_SKIP_RPATH=ON \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_INSTALL_DIR=/usr/lib${LIBDIRSUFFIX} \
+ -DLIB_INSTALL_DIR=/usr/lib${LIBDIRSUFFIX} \
-DLIBEXEC_INSTALL_DIR=/usr/lib${LIBDIRSUFFIX}/webkit2gtk-4.0 \
- -DENABLE_MEDIA_SOURCE=NO \
- -DUSE_GSTREAMER_GL=NO \
+ -DENABLE_MINIBROWSER=ON \
+ -DUSE_SYSTEMD=OFF \
..
make
make install DESTDIR=$PKG
diff --git a/libraries/webkit2gtk/webkit2gtk.info b/libraries/webkit2gtk/webkit2gtk.info
index 8c4164b2e7..b26395a7c4 100644
--- a/libraries/webkit2gtk/webkit2gtk.info
+++ b/libraries/webkit2gtk/webkit2gtk.info
@@ -1,10 +1,10 @@
PRGNAM="webkit2gtk"
-VERSION="2.20.5"
+VERSION="2.30.3"
HOMEPAGE="https://www.webkitgtk.org/"
-DOWNLOAD="https://www.webkitgtk.org/releases/webkitgtk-2.20.5.tar.xz"
-MD5SUM="72a05f6a4dc1c78b079590a8fd280401"
+DOWNLOAD="https://www.webkitgtk.org/releases/webkitgtk-2.30.3.tar.xz"
+MD5SUM="3db32cffeab82efcade1ce77f94865c2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="geoclue2 hyphen libwebp woff2"
+REQUIRES="bubblewrap enchant2 geoclue2 gst-plugins-bad libseccomp wpebackend-fdo xdg-dbus-proxy"
MAINTAINER="Willy Sudiarto Raharjo"
EMAIL="willysr@slackbuilds.org"