summaryrefslogtreecommitdiffstats
path: root/libraries/webkit2gtk/webkit2gtk.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/webkit2gtk/webkit2gtk.SlackBuild')
-rw-r--r--libraries/webkit2gtk/webkit2gtk.SlackBuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/libraries/webkit2gtk/webkit2gtk.SlackBuild b/libraries/webkit2gtk/webkit2gtk.SlackBuild
index d54d9bfc36..d1da46bf36 100644
--- a/libraries/webkit2gtk/webkit2gtk.SlackBuild
+++ b/libraries/webkit2gtk/webkit2gtk.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=webkit2gtk
SRCNAM=webkitgtk
-VERSION=${VERSION:-2.20.5}
+VERSION=${VERSION:-2.30.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -74,16 +74,22 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# ensure backward compatibility with the latest version of icu:
+# http://linuxfromscratch.org/blfs/view/svn/x/webkitgtk.html
+echo 'add_compile_definitions("U_DEFINE_FALSE_AND_TRUE=1")' >> Source/WTF/wtf/CMakeLists.txt
+
mkdir -p build
cd build
cmake -DPORT=GTK \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_SKIP_RPATH=ON \
+ -DCMAKE_SKIP_RPATH=ON \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_INSTALL_DIR=/usr/lib${LIBDIRSUFFIX} \
+ -DLIB_INSTALL_DIR=/usr/lib${LIBDIRSUFFIX} \
-DLIBEXEC_INSTALL_DIR=/usr/lib${LIBDIRSUFFIX}/webkit2gtk-4.0 \
- -DENABLE_MEDIA_SOURCE=NO \
- -DUSE_GSTREAMER_GL=NO \
+ -DENABLE_MINIBROWSER=ON \
+ -DUSE_SYSTEMD=OFF \
..
make
make install DESTDIR=$PKG