summaryrefslogtreecommitdiffstats
path: root/libraries/uriparser/uriparser.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/uriparser/uriparser.SlackBuild')
-rw-r--r--libraries/uriparser/uriparser.SlackBuild37
1 files changed, 17 insertions, 20 deletions
diff --git a/libraries/uriparser/uriparser.SlackBuild b/libraries/uriparser/uriparser.SlackBuild
index 00b9142000..32944960ac 100644
--- a/libraries/uriparser/uriparser.SlackBuild
+++ b/libraries/uriparser/uriparser.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for uriparser
-# Copyright 2015-2018 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# Copyright 2015-2019 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=uriparser
-VERSION=${VERSION:-0.9.1}
+VERSION=${VERSION:-0.9.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,24 +71,21 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# fix docs installation errors - thanks fedora!
-sed -i -e 's,html/\*.map\ ,,g' doc/Makefile.in || exit 1
-sed -i -e 's,-\$(INSTALL_DATA) \*.qch "$(DESTDIR)\$(docdir)/",,g' doc/Makefile.in || exit 1
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --disable-test \
- --disable-static \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
+# Test building is disabled ATM because we haven't an up2date gtest
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DMAN_INSTALL_DIR=/usr/man \
+ -DCMAKE_INSTALL_DOCDIR=/usr/doc/$PRGNAM-$VERSION \
+ -DURIPARSER_BUILD_TESTS=OFF \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true