summaryrefslogtreecommitdiffstats
path: root/libraries/rxtx/destdir.patch
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/rxtx/destdir.patch')
-rw-r--r--libraries/rxtx/destdir.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/libraries/rxtx/destdir.patch b/libraries/rxtx/destdir.patch
new file mode 100644
index 0000000000..421fffe38f
--- /dev/null
+++ b/libraries/rxtx/destdir.patch
@@ -0,0 +1,20 @@
+--- rxtx-2.2pre2_original/Makefile.in 2008-12-31 02:29:12.000000000 +0000
++++ rxtx-2.2pre2_patched/Makefile.in 2009-12-21 12:34:37.099017471 +0000
+@@ -619,13 +619,15 @@
+ # install librxtxSerial.so into the proper directory and copy $(JARTARGET) to its
+ # proper location
+ install: all
++ $(INSTALL_PROGRAM) -d $(DESTDIR)$(RXTX_PATH)
+ @$(LIBTOOL_INST) \
+ `for i in $(TARGETLIB);do \
+ if [ -f $$i ];then \
+ echo $$i; \
+ fi; \
+- done` $(RXTX_PATH)
+- $(INSTALL_PROGRAM) $(JARTARGET) $(JHOME)/
++ done` $(DESTDIR)$(RXTX_PATH)
++ $(INSTALL_PROGRAM) -d $(DESTDIR)$(JHOME)
++ $(INSTALL_DATA) $(JARTARGET) $(DESTDIR)$(JHOME)/
+
+ clean-generic:
+ rm -rf $(DEST) $(TOP)/$(CLASSTOP)