summaryrefslogtreecommitdiffstats
path: root/libraries/reportlab/reportlab.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/reportlab/reportlab.SlackBuild')
-rw-r--r--libraries/reportlab/reportlab.SlackBuild125
1 files changed, 0 insertions, 125 deletions
diff --git a/libraries/reportlab/reportlab.SlackBuild b/libraries/reportlab/reportlab.SlackBuild
deleted file mode 100644
index 303ed0ff7e..0000000000
--- a/libraries/reportlab/reportlab.SlackBuild
+++ /dev/null
@@ -1,125 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for reportlab
-
-# Copyright 2007-2015 LukenShiro, Italy
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Modified by SlackBuilds.org
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=reportlab
-VERSION=${VERSION:-3.2.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- LIBDIRSUFFIX="64"
-else
- LIBDIRSUFFIX=""
-fi
-
-# directory for python packages
-PYTHONDIR=$(python -c "import sys, os; print os.path.join('/usr/lib${LIBDIRSUFFIX}', 'python%s' % sys.version[:3], 'site-packages')")
-
-DOCFILES="CHANGES.md LICENSE.txt README.txt INSTALL.txt docs/*.pdf"
-OTHERPYFILES="demos tools tests"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Unzip T1 font curves
-cd src/reportlab/fonts/
-unzip $CWD/pfbfer-20070710.zip
-cd -
-
-# Generate pdf documentation
-( cd docs
- # workaround due to dependency loop if reportlab isn't previously installed
- PYTHONPATH=$PYTHONPATH:$TMP/$PRGNAM-$VERSION/src/ python genAll.py
-)
-
-# Move demos, tests and tools directories into python package's home
-# and remove duplicated file
-mkdir -p $PKG/$PYTHONDIR/$PRGNAM/
-mv $OTHERPYFILES $PKG/$PYTHONDIR/$PRGNAM
-rm -f $PKG/$PYTHONDIR/$PRGNAM/tools/docco/*.pdf
-
-# Fix some fonts search paths
-sed -i \
- -e "s|usr/share/fonts/truetype|usr/share/fonts/TTF|" \
- -e "s|usr/local/Acrobat9|opt/Adobe/Reader9|" \
- -e "s|%(HOME)s/fonts|%(HOME)s/.fonts|" \
- src/reportlab/rl_config.py || exit 1
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# Move documentation .pdf files and text files to avoid file duplication in
-# python directory
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-mv $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION/
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE