summaryrefslogtreecommitdiffstats
path: root/libraries/python-distutils-extra/python-distutils-extra.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/python-distutils-extra/python-distutils-extra.SlackBuild')
-rw-r--r--libraries/python-distutils-extra/python-distutils-extra.SlackBuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/libraries/python-distutils-extra/python-distutils-extra.SlackBuild b/libraries/python-distutils-extra/python-distutils-extra.SlackBuild
index 78198848d6..365401b382 100644
--- a/libraries/python-distutils-extra/python-distutils-extra.SlackBuild
+++ b/libraries/python-distutils-extra/python-distutils-extra.SlackBuild
@@ -5,16 +5,14 @@
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
PRGNAM=python-distutils-extra
-VERSION=2.18
+VERSION=2.23
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -30,7 +28,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/dist-$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
@@ -41,15 +39,8 @@ find . \
python setup.py install --root=$PKG
-# Get rid of *.pyc files.
-find $PKG -name "*.pyc" -exec rm -f {} \;
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null || true
-)
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \