summaryrefslogtreecommitdiffstats
path: root/libraries/pymediainfo/pymediainfo.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/pymediainfo/pymediainfo.SlackBuild')
-rw-r--r--libraries/pymediainfo/pymediainfo.SlackBuild26
1 files changed, 6 insertions, 20 deletions
diff --git a/libraries/pymediainfo/pymediainfo.SlackBuild b/libraries/pymediainfo/pymediainfo.SlackBuild
index 9c19a06e82..ff3d6927c0 100644
--- a/libraries/pymediainfo/pymediainfo.SlackBuild
+++ b/libraries/pymediainfo/pymediainfo.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for pymediainfo
# Copyright 2014-2021 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2023 Jeremy Hansen jebrhansen+SBo@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pymediainfo
-VERSION=${VERSION:-5.0.3}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-6.1.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -79,13 +63,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
+
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install