summaryrefslogtreecommitdiffstats
path: root/libraries/pymdstat/pymdstat.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/pymdstat/pymdstat.SlackBuild')
-rw-r--r--libraries/pymdstat/pymdstat.SlackBuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/libraries/pymdstat/pymdstat.SlackBuild b/libraries/pymdstat/pymdstat.SlackBuild
index 0971d96085..7f1b8562db 100644
--- a/libraries/pymdstat/pymdstat.SlackBuild
+++ b/libraries/pymdstat/pymdstat.SlackBuild
@@ -1,8 +1,8 @@
#!/bin/sh
-# Slackware build script for PyMDstat
+# Slackware build script for pymdstat
-# Copyright 2015 Philip Lacroix <philnx at posteo dot de>
+# Copyright 2015 Philip Lacroix <slackph at posteo dot de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -47,8 +47,8 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-# The upstream tarball will be named differently, depending on the file
-# being downloaded manually (web browser) or with wget.
+# The upstream tarball will be named differently, depending on
+# the file being downloaded manually (web browser) or with wget.
if [ -e $CWD/v$VERSION.tar.gz ]; then
tar xvzf $CWD/v$VERSION.tar.gz
else
@@ -63,10 +63,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
-o -perm 400 \) -exec chmod 644 {} \;
-PRGUSR=$PKG/usr
-PRGSHR=$PKG/usr/share
-PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
-
python setup.py install --root=$PKG
# Python 3 support.
@@ -75,9 +71,13 @@ if $(python3 -c 'import sys' 2>/dev/null); then
fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
- | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null \
- || true
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+PRGUSR=$PKG/usr
+PRGSHR=$PKG/usr/share
+PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+# Install documentation.
mkdir -p $PRGDOC
mv $PRGSHR/doc/$PRGNAM/* $PRGDOC/
rm -rf $PRGSHR