summaryrefslogtreecommitdiffstats
path: root/libraries/pyftpdlib/pyftpdlib.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/pyftpdlib/pyftpdlib.SlackBuild')
-rw-r--r--libraries/pyftpdlib/pyftpdlib.SlackBuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/libraries/pyftpdlib/pyftpdlib.SlackBuild b/libraries/pyftpdlib/pyftpdlib.SlackBuild
index ab3fed5d84..787fa9020f 100644
--- a/libraries/pyftpdlib/pyftpdlib.SlackBuild
+++ b/libraries/pyftpdlib/pyftpdlib.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyftpdlib
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,9 +22,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
PRGNAM=pyftpdlib
-VERSION=${VERSION:-1.4.0}
+VERSION=${VERSION:-1.5.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -68,7 +67,10 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Fix setup install messages
+patch -p1 < $CWD/setup.patch
python setup.py install --root=$PKG