summaryrefslogtreecommitdiffstats
path: root/libraries/pyacoustid/pyacoustid.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/pyacoustid/pyacoustid.SlackBuild')
-rw-r--r--libraries/pyacoustid/pyacoustid.SlackBuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/libraries/pyacoustid/pyacoustid.SlackBuild b/libraries/pyacoustid/pyacoustid.SlackBuild
index 5471516fc7..465a6eced0 100644
--- a/libraries/pyacoustid/pyacoustid.SlackBuild
+++ b/libraries/pyacoustid/pyacoustid.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyacoustid
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pyacoustid
-VERSION=${VERSION:-1.2.2}
+VERSION=${VERSION:-1.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -60,14 +57,14 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
-PYTHON=python3
-[ "${PYTHON2:-no}" = "yes" ] && PYTHON=python2
-
set -e
rm -rf $PKG
@@ -79,11 +76,11 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-$PYTHON setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true