summaryrefslogtreecommitdiffstats
path: root/libraries/portsmf/portsmf_sharedlib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/portsmf/portsmf_sharedlib.patch')
-rw-r--r--libraries/portsmf/portsmf_sharedlib.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/libraries/portsmf/portsmf_sharedlib.patch b/libraries/portsmf/portsmf_sharedlib.patch
new file mode 100644
index 0000000000..90815a4efb
--- /dev/null
+++ b/libraries/portsmf/portsmf_sharedlib.patch
@@ -0,0 +1,35 @@
+--- portsmf/configure.ac.orig 2013-06-22 20:54:59.000000000 +0200
++++ portsmf/configure.ac 2013-06-22 21:52:25.212040115 +0200
+@@ -23,7 +23,7 @@
+ dnl keep autools files in a subdirectory
+ AC_CONFIG_AUX_DIR(autotools)
+ # which also contains a subdir containing macros
+-AC_CONFIG_MACRO_DIR([autotools/m4])
++dnl AC_CONFIG_MACRO_DIR([autotools/m4])
+ dnl set up automake
+ AM_INIT_AUTOMAKE([-Wall foreign])
+ dnl Audacity policy: don't enable automatic rebuild of configure et al if
+@@ -49,7 +49,7 @@
+ dnl we will need an "install" program to be available
+ AC_PROG_INSTALL
+ dnl and ranlib for static libraries
+-AC_PROG_RANLIB
++AC_PROG_LIBTOOL
+
+ dnl Make the install prefix available to the program so that the pkg-config file
+ dnl can be created correctly
+--- portsmf/Makefile.am.orig 2013-06-22 20:55:00.000000000 +0200
++++ portsmf/Makefile.am 2013-06-22 21:52:52.898705781 +0200
+@@ -6,10 +6,10 @@
+ ACLOCAL_AMFLAGS = -I autotools/m4
+
+ # define the output library (link with -lportSMF)
+-lib_LIBRARIES = libportSMF.a
++lib_LTLIBRARIES = libportSMF.la
+
+ # define the source files to use
+-libportSMF_a_SOURCES = allegro.cpp \
++libportSMF_la_SOURCES = allegro.cpp \
+ allegrosmfwr.cpp \
+ allegrord.cpp \
+ allegrowr.cpp \