summaryrefslogtreecommitdiffstats
path: root/libraries/poco
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/poco')
-rw-r--r--libraries/poco/README16
-rw-r--r--libraries/poco/poco.SlackBuild19
-rw-r--r--libraries/poco/poco.info10
-rw-r--r--libraries/poco/poco_mariadb.patch12
4 files changed, 45 insertions, 12 deletions
diff --git a/libraries/poco/README b/libraries/poco/README
index 452ba36447..353a2b4c50 100644
--- a/libraries/poco/README
+++ b/libraries/poco/README
@@ -1,6 +1,12 @@
-Modern, powerful open source C++ class libraries and
-frameworks for building network- and internet-based
-applications that run on desktop, server, mobile and
-embedded systems.
+Modern, powerful open source C++ class libraries and frameworks for
+building network- and internet-based applications that run on desktop,
+server, mobile and embedded systems.
+
+PostgreSQL (on Sbo) and libiodbc (part of Slackware) or UnixODBC
+(on SBo) are optional dependencies that will be automatically picked
+up during configuration. If you have PostgreSQL installed and want to
+compile the corresponding database connector, do this:
+
+ POSTGRESQL=yes ./poco.SlackBuild
+
-Optional dependencies: mysql-connector-c++, unixODBC
diff --git a/libraries/poco/poco.SlackBuild b/libraries/poco/poco.SlackBuild
index d215d2a60c..f941dbb2b7 100644
--- a/libraries/poco/poco.SlackBuild
+++ b/libraries/poco/poco.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for poco
-# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2022 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 29-DEC-2022: new maintainer, Edward W. Koenig (kingbeowulf)
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=poco
-VERSION=${VERSION:-1.9.4}
+VERSION=${VERSION:-1.12.5}
EDITION=all
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
@@ -47,6 +49,14 @@ if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
exit 0
fi
+# Make optionally detected components really optional as they are in
+# CMAKE build configuration upstream.
+if [ ${POSTGRESQL:-no} = "no" ]; then
+ NOPOSTGRESQL="--omit=Data/PostgreSQL"
+else
+ NOPOSTGRESQL=""
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -84,10 +94,15 @@ if [ "$ARCH" = "x86_64" ]; then
patch -p1 < $CWD/poco_x64.patch
fi
+# Slackware ships with MariaDB not MySQL, patch from Arch Linux
+patch -p1 < $CWD/poco_mariadb.patch
+
./configure \
--prefix=/usr \
--no-tests \
--no-samples \
+ $NOPOSTGRESQL \
+ --sqlite-thread-safe=2 \
--shared
make
diff --git a/libraries/poco/poco.info b/libraries/poco/poco.info
index f2dfe6910f..e2bd2787b7 100644
--- a/libraries/poco/poco.info
+++ b/libraries/poco/poco.info
@@ -1,10 +1,10 @@
PRGNAM="poco"
-VERSION="1.9.4"
+VERSION="1.12.5"
HOMEPAGE="https://pocoproject.org"
-DOWNLOAD="https://pocoproject.org/releases/poco-1.9.4/poco-1.9.4-all.tar.gz"
-MD5SUM="80c614193e81262af27ea49944d02313"
+DOWNLOAD="https://pocoproject.org/releases/poco-1.12.5/poco-1.12.5-all.tar.gz"
+MD5SUM="5bdbf497ff3e65d92a66ecae0a963397"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+MAINTAINER="Edward W. Koenig"
+EMAIL="kingbeowulf@linuxgalaxy.org"
diff --git a/libraries/poco/poco_mariadb.patch b/libraries/poco/poco_mariadb.patch
new file mode 100644
index 0000000000..c8a82ec79e
--- /dev/null
+++ b/libraries/poco/poco_mariadb.patch
@@ -0,0 +1,12 @@
+diff -uNr poco/Data/MySQL/CMakeLists.txt poco_changed/Data/MySQL/CMakeLists.txt
+--- poco/Data/MySQL/CMakeLists.txt 2021-06-28 12:16:01.000000000 +0200
++++ poco_changed/Data/MySQL/CMakeLists.txt 2021-10-14 14:53:52.605311071 +0200
+@@ -21,7 +21,7 @@
+ DEFINE_SYMBOL MySQL_EXPORTS
+ )
+
+-target_link_libraries(DataMySQL PUBLIC Poco::Data MySQL::client)
++target_link_libraries(DataMySQL PUBLIC Poco::Data mariadb)
+ target_include_directories(DataMySQL
+ PUBLIC
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>