summaryrefslogtreecommitdiffstats
path: root/libraries/poco/poco_mariadb.patch
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/poco/poco_mariadb.patch')
-rw-r--r--libraries/poco/poco_mariadb.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/libraries/poco/poco_mariadb.patch b/libraries/poco/poco_mariadb.patch
new file mode 100644
index 0000000000..c8a82ec79e
--- /dev/null
+++ b/libraries/poco/poco_mariadb.patch
@@ -0,0 +1,12 @@
+diff -uNr poco/Data/MySQL/CMakeLists.txt poco_changed/Data/MySQL/CMakeLists.txt
+--- poco/Data/MySQL/CMakeLists.txt 2021-06-28 12:16:01.000000000 +0200
++++ poco_changed/Data/MySQL/CMakeLists.txt 2021-10-14 14:53:52.605311071 +0200
+@@ -21,7 +21,7 @@
+ DEFINE_SYMBOL MySQL_EXPORTS
+ )
+
+-target_link_libraries(DataMySQL PUBLIC Poco::Data MySQL::client)
++target_link_libraries(DataMySQL PUBLIC Poco::Data mariadb)
+ target_include_directories(DataMySQL
+ PUBLIC
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>