summaryrefslogtreecommitdiffstats
path: root/libraries/physfs/physfs.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/physfs/physfs.SlackBuild')
-rw-r--r--libraries/physfs/physfs.SlackBuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/libraries/physfs/physfs.SlackBuild b/libraries/physfs/physfs.SlackBuild
index f7abcc5492..5ee10e504f 100644
--- a/libraries/physfs/physfs.SlackBuild
+++ b/libraries/physfs/physfs.SlackBuild
@@ -2,7 +2,7 @@
#
# Slackware build script for physfs
#
-# Copyright 2009-2010 Erik W. Hanson, Minneapolis, MN, USA
+# Copyright 2009-2011 Erik W. Hanson, Minneapolis, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=physfs
-VERSION=2.0.1
-BUILD=${BUILD:-3}
+VERSION=2.0.2
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -65,11 +65,6 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R a-s,u+w,go+r-w .
-# LIB_SUFFIX is ignored, work around it.
-sed -i -e "s|DESTINATION lib|DESTINATION lib${LIBDIRSUFFIX}|g" \
- -e "s:-Werror::" \
- CMakeLists.txt
-
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \