summaryrefslogtreecommitdiffstats
path: root/libraries/mysql-connector-c++
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/mysql-connector-c++')
-rw-r--r--libraries/mysql-connector-c++/README1
-rw-r--r--libraries/mysql-connector-c++/mariadb_api.patch13
-rw-r--r--libraries/mysql-connector-c++/mysql-connector-c++.SlackBuild105
-rw-r--r--libraries/mysql-connector-c++/mysql-connector-c++.info10
-rw-r--r--libraries/mysql-connector-c++/slack-desc19
5 files changed, 0 insertions, 148 deletions
diff --git a/libraries/mysql-connector-c++/README b/libraries/mysql-connector-c++/README
deleted file mode 100644
index df142568e3..0000000000
--- a/libraries/mysql-connector-c++/README
+++ /dev/null
@@ -1 +0,0 @@
-mysql-connector-c++ is the official c++ driver for MySQL
diff --git a/libraries/mysql-connector-c++/mariadb_api.patch b/libraries/mysql-connector-c++/mariadb_api.patch
deleted file mode 100644
index c7c8a5913e..0000000000
--- a/libraries/mysql-connector-c++/mariadb_api.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/driver/nativeapi/libmysql_static_proxy.cpp b/driver/nativeapi/libmysql_static_proxy.cpp
-index 703c0f3..1569e55 100644
---- a/driver/nativeapi/libmysql_static_proxy.cpp
-+++ b/driver/nativeapi/libmysql_static_proxy.cpp
-@@ -319,7 +319,7 @@ LibmysqlStaticProxy::options(MYSQL * mysql, enum mysql_option option, const void
- int
- LibmysqlStaticProxy::get_option(MYSQL * mysql, enum mysql_option option, const void *arg)
- {
--#if MYSQL_VERSION_ID >= 50703
-+#if not defined MARIADB_BASE_VERSION && MYSQL_VERSION_ID >= 50703
- if (::mysql_get_option(mysql, option, arg)) {
- throw sql::InvalidArgumentException("Unsupported option provided to mysql_get_option()");
- } else {
diff --git a/libraries/mysql-connector-c++/mysql-connector-c++.SlackBuild b/libraries/mysql-connector-c++/mysql-connector-c++.SlackBuild
deleted file mode 100644
index d0d23c7630..0000000000
--- a/libraries/mysql-connector-c++/mysql-connector-c++.SlackBuild
+++ /dev/null
@@ -1,105 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for mysql-connector-c++
-
-# Copyright 2013-2022 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# 20220419 bkw: Modified by SlackBuilds.org, BUILD=2:
-# - move a couple of doc files from /usr to the actual doc dir.
-# - do not include CMakeLists.txt in the doc dir.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=mysql-connector-c++
-VERSION=${VERSION:-8.0.31}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION-src
-tar xvf $CWD/$PRGNAM-$VERSION-src.tar.gz
-cd $PRGNAM-$VERSION-src
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \+ -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib${LIBDIRSUFFIX} \
- -DCMAKE_BUILD_TYPE=Release ..
- make
- make install/strip DESTDIR=$PKG
-cd ..
-
-PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
-mkdir -p $PKGDOC
-rm -f CMakeLists.txt # 20220419 bkw: not documentation.
-cp -a *.txt *.md $PKGDOC
-mv $PKG/usr/INFO_* $PKGDOC # 20220419 bkw: this *is* documentation.
-cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/mysql-connector-c++/mysql-connector-c++.info b/libraries/mysql-connector-c++/mysql-connector-c++.info
deleted file mode 100644
index 8c74af6827..0000000000
--- a/libraries/mysql-connector-c++/mysql-connector-c++.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="mysql-connector-c++"
-VERSION="8.0.31"
-HOMEPAGE="https://dev.mysql.com/downloads/connector/cpp/"
-DOWNLOAD="https://dev.mysql.com/get/Downloads/Connector-C++/mysql-connector-c++-8.0.31-src.tar.gz"
-MD5SUM="e51d571fe37c75adfc84901b56caefe7"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Willy Sudiarto Raharjo"
-EMAIL="willysr@slackbuilds.org"
diff --git a/libraries/mysql-connector-c++/slack-desc b/libraries/mysql-connector-c++/slack-desc
deleted file mode 100644
index bde9eb3a39..0000000000
--- a/libraries/mysql-connector-c++/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-mysql-connector-c++: mysql-connector-c++ (MySQL Connector in C++)
-mysql-connector-c++:
-mysql-connector-c++: mysql-connector-c++ is the official c++ driver for MySQL.
-mysql-connector-c++:
-mysql-connector-c++: Website: http://www.mysql.com/
-mysql-connector-c++:
-mysql-connector-c++:
-mysql-connector-c++:
-mysql-connector-c++:
-mysql-connector-c++:
-mysql-connector-c++: