summaryrefslogtreecommitdiffstats
path: root/libraries/msgpack-c/msgpack-c.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/msgpack-c/msgpack-c.SlackBuild')
-rw-r--r--libraries/msgpack-c/msgpack-c.SlackBuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/libraries/msgpack-c/msgpack-c.SlackBuild b/libraries/msgpack-c/msgpack-c.SlackBuild
index 938d027d7b..92d7d21e4b 100644
--- a/libraries/msgpack-c/msgpack-c.SlackBuild
+++ b/libraries/msgpack-c/msgpack-c.SlackBuild
@@ -2,6 +2,7 @@
# SlackBuild script for msgpack-c
+# Copyright 2024 Giancarlo Dessi, Cagliari, IT
# Copyright 2021 Ruben Schuller <sb@rbn.im>
# Copyright 2014-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
@@ -30,7 +31,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=msgpack-c
VERSION=${VERSION:-3.3.0}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -81,6 +82,7 @@ find -L . \
-o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+sed -i ./CMakeLists.txt -e "s/(VERSION 2.8.12)/(VERSION 3.5)/g"
mkdir -p build
cd build
@@ -90,6 +92,8 @@ cd build
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=/usr/lib${LIBDIRSUFFIX} \
+ -DMSGPACK_BUILD_TESTS=OFF \
+ -DMSGPACK_BUILD_EXAMPLES=OFF \
..
make install/strip DESTDIR=$PKG
cd ..