summaryrefslogtreecommitdiffstats
path: root/libraries/matplotlib/matplotlib.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/matplotlib/matplotlib.SlackBuild')
-rw-r--r--libraries/matplotlib/matplotlib.SlackBuild32
1 files changed, 27 insertions, 5 deletions
diff --git a/libraries/matplotlib/matplotlib.SlackBuild b/libraries/matplotlib/matplotlib.SlackBuild
index d50fcb6e1b..980d4a7256 100644
--- a/libraries/matplotlib/matplotlib.SlackBuild
+++ b/libraries/matplotlib/matplotlib.SlackBuild
@@ -2,17 +2,38 @@
# Slackware build script for matplotlib
+# Copyright 2011-2016 Serban Udrea <s.udrea@gsi.de>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification,
+# is permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR
+# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
+# INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
+# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+# POSSIBILITY OF SUCH DAMAGE.
+
# Written by Aleksandar Samardzic <asamardzic@gmail.com>
# Updated to 0.99.1.2 by João Felipe Santos <joao.eel@gmail.com>
# Patch for libpng borrowed from Arch Linux
-# Updated up to version 1.4.1 by Serban Udrea <S.Udrea@gsi.de>
+# Updated up to version 1.5.2 by Serban Udrea <S.Udrea@gsi.de>
PRGNAM=matplotlib
-VERSION=${VERSION:-1.4.2}
+VERSION=${VERSION:-1.5.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-TARBALL_VERSION=1.4.2 # Tarball sometimes has a wrong version number
+TARBALL_VERSION=${TARBALL_VERSION:-1.5.2} # Tarball sometimes has a wrong version number
DISABLE_TESTS=${DISABLE_TESTS:-Y}
DISABLE_TK_TESTS=${DISABLE_TK_TESTS:-Y}
@@ -46,6 +67,7 @@ find -L . \
# Use setup.cfg to decide about the optional subpackages tests and
# toolkits_tests
+#
cat setup.cfg.template > setup.cfg
DISABLE_TESTS=$(echo "$DISABLE_TESTS"|cut -b 1|tr a-z A-Z)
@@ -69,10 +91,10 @@ fi
# Use modified setupext.py to make sure that the build process gets
# interrupted if requirements are not fulfilled
-
+#
cat "${CWD}/setupext.py" > setupext.py
-python setup.py install --root $PKG # > ${CWD}/SETUP.OUTPUT 2>&1
+python setup.py install --root $PKG # > ${CWD}/SETUP.OUTPUT 2>&1
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true