summaryrefslogtreecommitdiffstats
path: root/libraries/matplotlib/matplotlib.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/matplotlib/matplotlib.SlackBuild')
-rw-r--r--libraries/matplotlib/matplotlib.SlackBuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/libraries/matplotlib/matplotlib.SlackBuild b/libraries/matplotlib/matplotlib.SlackBuild
index 11ffa42bbd..517f7f61df 100644
--- a/libraries/matplotlib/matplotlib.SlackBuild
+++ b/libraries/matplotlib/matplotlib.SlackBuild
@@ -5,20 +5,19 @@
# Written by Aleksandar Samardzic <asamardzic@gmail.com>
# Updated to 0.99.1.2 by João Felipe Santos <joao.eel@gmail.com>
# Patch for libpng borrowed from Arch Linux
+# Updated for version 1.1.0 by Serban Udrea <S.Udrea@gsi.de>
PRGNAM=matplotlib
-VERSION=${VERSION:-0.99.1.2}
+VERSION=${VERSION:-1.1.0}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
-TARBALL_VERSION=0.99.1.1 # Tarball dir has wrong version number
+TARBALL_VERSION=1.1.0 # Tarball sometimes has a wrong version number
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -43,7 +42,7 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-patch -p1 < $CWD/libpng-1.4.patch
+# patch -p1 < $CWD/libpng-1.4.patch # Does not seem to be needed anymore
# Use setup.cfg to tell setup.py not to install pytz and dateutil
mv setup.cfg.template setup.cfg
@@ -57,7 +56,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- CHANGELOG INSTALL INTERACTIVE KNOWN_BUGS README.txt TODO \
+ CHANGELOG INSTALL README.txt TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild