summaryrefslogtreecommitdiffstats
path: root/libraries/matplotlib/matplotlib.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/matplotlib/matplotlib.SlackBuild')
-rw-r--r--libraries/matplotlib/matplotlib.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/libraries/matplotlib/matplotlib.SlackBuild b/libraries/matplotlib/matplotlib.SlackBuild
index 36fe64f31f..11ffa42bbd 100644
--- a/libraries/matplotlib/matplotlib.SlackBuild
+++ b/libraries/matplotlib/matplotlib.SlackBuild
@@ -8,7 +8,7 @@
PRGNAM=matplotlib
VERSION=${VERSION:-0.99.1.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
TARBALL_VERSION=0.99.1.1 # Tarball dir has wrong version number
@@ -45,13 +45,18 @@ find . \
patch -p1 < $CWD/libpng-1.4.patch
+# Use setup.cfg to tell setup.py not to install pytz and dateutil
+mv setup.cfg.template setup.cfg
+sed -i "s|#pytz|pytz|" setup.cfg
+sed -i "s|#dateutil|dateutil|" setup.cfg
+
python setup.py install --root $PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-install -m 0644 \
+cp -a \
CHANGELOG INSTALL INTERACTIVE KNOWN_BUGS README.txt TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild