summaryrefslogtreecommitdiffstats
path: root/libraries/libpoly
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libpoly')
-rw-r--r--libraries/libpoly/README10
-rw-r--r--libraries/libpoly/libpoly.SlackBuild145
-rw-r--r--libraries/libpoly/libpoly.info10
-rw-r--r--libraries/libpoly/slack-desc19
4 files changed, 184 insertions, 0 deletions
diff --git a/libraries/libpoly/README b/libraries/libpoly/README
new file mode 100644
index 0000000000..64b6fe3226
--- /dev/null
+++ b/libraries/libpoly/README
@@ -0,0 +1,10 @@
+ LibPoly is a C library for manipulating polynomials. The target
+applications are symbolic reasoning engines, such as SMT solvers,
+that need to reason about polynomial constraints. It is research
+software under development, so the features and the API might
+change rapidly.
+
+
+ If you want to build the python API, set PYTHON=yes to the
+environment variables. By default it uses python2, if you want to
+use python3 set PYTHON3=yes.
diff --git a/libraries/libpoly/libpoly.SlackBuild b/libraries/libpoly/libpoly.SlackBuild
new file mode 100644
index 0000000000..094aa4a8b3
--- /dev/null
+++ b/libraries/libpoly/libpoly.SlackBuild
@@ -0,0 +1,145 @@
+#!/bin/bash
+
+# Slackware build script for libpoly
+
+# Copyright 2022 William PC - Seattle, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=libpoly
+VERSION=${VERSION:-0.1.11}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=yices-$VERSION-src
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+if [ "${PYTHON:-no}" == "yes" ]; then
+ OPT_BUILD="-DLIBPOLY_BUILD_PYTHON_API=ON"
+else
+ OPT_BUILD="-DLIBPOLY_BUILD_PYTHON_API=OFF"
+fi
+
+if [ "${PYTHON3:-no}" == "yes" ]; then
+ OPT_BUILD="$OPT_BUILD -DPython_ADDITIONAL_VERSIONS=3"
+ SITE_PACKAGES=$(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")
+else
+ SITE_PACKAGES=$(python2 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")
+fi
+
+# fix library installation
+sed -i '99,100s/DESTINATION lib/&'${LIBDIRSUFFIX}'/' src/CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIBPOLY_BUILD_STATIC=OFF \
+ -DLIBPOLY_BUILD_STATIC_PIC=OFF \
+ $OPT_BUILD \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make test
+ make install/strip DESTDIR=$PKG
+cd ..
+
+# there is not make rule to install the python API,
+# performing it manually
+if [ "${PYTHON:-no}" == "yes" ]; then
+ mkdir -p $PKG/$SITE_PACKAGES
+ cp -av build/python/polypy.so $PKG/$SITE_PACKAGES
+fi
+
+# installing examples
+mkdir -p $PKG/usr/share/$PRGNAM-$VERSION
+cp -a examples $PKG/usr/share/$PRGNAM-$VERSION
+
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENCE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/libpoly/libpoly.info b/libraries/libpoly/libpoly.info
new file mode 100644
index 0000000000..61c08fbbbd
--- /dev/null
+++ b/libraries/libpoly/libpoly.info
@@ -0,0 +1,10 @@
+PRGNAM="libpoly"
+VERSION="0.1.11"
+HOMEPAGE="http://sri-csl.github.io/libpoly"
+DOWNLOAD="https://github.com/SRI-CSL/libpoly/archive/v0.1.11/libpoly-0.1.11.tar.gz"
+MD5SUM="ceb5155194bd5845e8081f211f10fe69"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="William PC"
+EMAIL="w_calandrini[at]hotmail[dot]com"
diff --git a/libraries/libpoly/slack-desc b/libraries/libpoly/slack-desc
new file mode 100644
index 0000000000..6288867bb5
--- /dev/null
+++ b/libraries/libpoly/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+libpoly: libpoly (LibPoly - C library for manipulating polynomials)
+libpoly:
+libpoly:
+libpoly: LibPoly is a C library for manipulating polynomials. The target
+libpoly: applications are symbolic reasoning engines, such as SMT solvers,
+libpoly: that need to reason about polynomial constraints. It is research
+libpoly: software under development, so the features and the API might
+libpoly: change rapidly.
+libpoly:
+libpoly:
+libpoly: