summaryrefslogtreecommitdiffstats
path: root/libraries/libevdevplus/libevdevplus.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libevdevplus/libevdevplus.SlackBuild')
-rw-r--r--libraries/libevdevplus/libevdevplus.SlackBuild99
1 files changed, 0 insertions, 99 deletions
diff --git a/libraries/libevdevplus/libevdevplus.SlackBuild b/libraries/libevdevplus/libevdevplus.SlackBuild
deleted file mode 100644
index 704372bf29..0000000000
--- a/libraries/libevdevplus/libevdevplus.SlackBuild
+++ /dev/null
@@ -1,99 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for libevdevplus
-
-# Written by B. Watson (urchlay@slackware.uk)
-
-# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
-
-# Note: this version of libevdevplus is not the latest. It was chosen
-# because it's compatible with ytodool-0.1.9. Later versions of
-# libevdevplus have API changes that break it, plus upstream dropped
-# support for building a shared library, and got rid of "make install"
-# entirely.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=libevdevplus
-VERSION=${VERSION:-0.1.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-SRCNAM=libevdevPlus
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_SKIP_RPATH=ON \
- -DCMAKE_CXX_FLAGS_RELEASE="$SLKCFLAGS -DNDEBUG" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_SUFFIX=${LIBDIRSUFFIX} \
- -DMAN_INSTALL_DIR=/usr/man \
- -DCMAKE_BUILD_TYPE=Release ..
- make VERBOSE=1
- make install/strip DESTDIR=$PKG
-cd ..
-
-# No cmake option to disable the static lib. Could patch CMakeLists.txt,
-# or just do this:
-rm -f $PKG/usr/lib*/*.a
-
-# This binary looks useful, but isn't installed by default.
-mkdir -p $PKG/usr/bin
-install -s build/evdevPlus_test $PKG/usr/bin
-
-# README.md is really just a placeholder. Include it to avoid people
-# wondering why there's no README.
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE* README* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE