summaryrefslogtreecommitdiffstats
path: root/libraries/libbluray/libbluray.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libbluray/libbluray.SlackBuild')
-rw-r--r--libraries/libbluray/libbluray.SlackBuild21
1 files changed, 8 insertions, 13 deletions
diff --git a/libraries/libbluray/libbluray.SlackBuild b/libraries/libbluray/libbluray.SlackBuild
index 5ca11aa1cc..aaedca104f 100644
--- a/libraries/libbluray/libbluray.SlackBuild
+++ b/libraries/libbluray/libbluray.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for libbluray
-# Copyright 2011-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2011-2014 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=libbluray
-VERSION=${VERSION:-0.5.0}
+VERSION=${VERSION:-0.6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -64,20 +64,17 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Hack for compiling xine plugin bindings for libbluray.
sed -i -e '/pkg-config libbluray/d' -e 's|0644|0755|' player_wrappers/xine/Makefile
# If you want bdjava enabled then set BDAJVA=yes to the slackbuild.
if [ "${BDJAVA:-no}" == 'yes' ]; then
- OPT_ARGS="--enable-bdjava JDK_HOME=$JAVA_HOME"
- sed -i \
- "s|/usr/lib/libbluray|/usr/lib${LIBDIRSUFFIX}/libbluray|" \
- src/libbluray/bdj/bdj.c
+ OPT_ARGS="--enable-bdjava"
else
OPT_ARGS="--disable-bdjava"
fi
@@ -105,9 +102,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- COPYING README.txt player_wrappers/xine/HOWTO \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING README.txt player_wrappers/xine/HOWTO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install