summaryrefslogtreecommitdiffstats
path: root/libraries/libROM
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libROM')
-rw-r--r--libraries/libROM/README13
-rw-r--r--libraries/libROM/libROM.SlackBuild135
-rw-r--r--libraries/libROM/libROM.info10
-rw-r--r--libraries/libROM/slack-desc19
4 files changed, 177 insertions, 0 deletions
diff --git a/libraries/libROM/README b/libraries/libROM/README
new file mode 100644
index 0000000000..1f353488e2
--- /dev/null
+++ b/libraries/libROM/README
@@ -0,0 +1,13 @@
+ libROM is a free, lightweight, scalable C++ library for data-driven
+physical simulation methods. It is the main tool box that the reduced
+order modeling team at LLNL uses to develop efficient model order
+reduction techniques and physics-constrained data-driven methods. We
+try to collect any useful reduced order model routines, which are
+separable to the high-fidelity physics solvers, into libROM. Plus,
+libROM is open source, so anyone is welcome to suggest new ideas or
+contribute to the development. Let's work together for better
+data-driven technology!
+
+
+ If you want to use MFEM set MFEM=yes, this requires the hypre, metis,
+parmetis and mfem package.
diff --git a/libraries/libROM/libROM.SlackBuild b/libraries/libROM/libROM.SlackBuild
new file mode 100644
index 0000000000..0ac8fc0089
--- /dev/null
+++ b/libraries/libROM/libROM.SlackBuild
@@ -0,0 +1,135 @@
+#!/bin/bash
+
+# Slackware build script for libROM
+
+# Copyright 2022 William PC, Seattle (USA)
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=libROM
+VERSION=${VERSION:-1.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+if [ ${MFEM:-no} == "yes" ]; then
+ OPTS="-DUSE_MFEM:BOOL=ON -DHYPRE_INCLUDES:STRING=/usr/include/hypre -DPARMETIS_INCLUDES:STRING=/usr/include/parmetis"
+ # don't build examples
+ sed -i '128s/if (USE_MFEM)/if ((USE_MFEM) AND (BUILD_EXAMPLES))/' CMakeLists.txt
+fi
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_STATIC:BOOL=OFF \
+ $OPTS \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ cd tests; for file in smoke_test test_include; do echo "Running $file"; ./$file; done; cd -
+ # none install rule
+cd ..
+
+install -d $PKG/usr/lib${LIBDIRSUFFIX}
+install -m 755 build/lib/libROM.so $PKG/usr/lib${LIBDIRSUFFIX}
+
+install -d $PKG/usr/include/$PRGNAM
+install -m 644 lib/{CAROM_config,FCMangle,librom}.h $PKG/usr/include/$PRGNAM
+cp -a lib/{algo,hyperreduction,linalg,mfem,utils} $PKG/usr/include/$PRGNAM
+
+# install examples
+mkdir -p $PKG/usr/share/$PRGNAM-$VERSION
+cp -av examples $PKG/usr/share/$PRGNAM-$VERSION
+cat << EOF > $PKG/usr/share/$PRGNAM-$VERSION/examples/build-all.sh
+for file in \$(ls {dmd,prom}/*.cpp);do
+ echo "compiling \$file"
+ g++ -o \${file%%.*} \$file -I/usr/include -I/usr/include/hypre -I/usr/include/libROM -Wl,-rpath -Wl,/usr/lib${LIBDIRSUFFIX} -Wl,--enable-new-dtags -pthread -lROM -Wl,-rpath -Wl,/usr/lib64 -Wl,--enable-new-dtags -pthread -lscalapack -lmpi -lhdf5 -llapack -lblas -lmfem -lHYPRE -lparmetis -lmetis
+done
+EOF
+
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYRIGHT LICENSE-APACHE LICENSE-MIT NOTICE docs \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/libROM/libROM.info b/libraries/libROM/libROM.info
new file mode 100644
index 0000000000..093602cd8f
--- /dev/null
+++ b/libraries/libROM/libROM.info
@@ -0,0 +1,10 @@
+PRGNAM="libROM"
+VERSION="1.0.0"
+HOMEPAGE="https://www.librom.net"
+DOWNLOAD="https://github.com/LLNL/libROM/archive/v1.0.0/libROM-1.0.0.tar.gz"
+MD5SUM="6a7365522766a61a89896e0f74a5b471"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="hdf5 scalapack"
+MAINTAINER="William PC"
+EMAIL="w_calandrini[at]hotmail[dot]com"
diff --git a/libraries/libROM/slack-desc b/libraries/libROM/slack-desc
new file mode 100644
index 0000000000..ad42753f67
--- /dev/null
+++ b/libraries/libROM/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+libROM: libROM (C++ library for data-driven physical simulation methods)
+libROM:
+libROM:
+libROM: libROM is a free, lightweight, scalable C++ library for data-driven
+libROM: physical simulation methods. It is the main tool box that the reduced
+libROM: order modeling team at LLNL uses to develop efficient model order
+libROM: reduction techniques and physics-constrained data-driven methods. We
+libROM: try to collect any useful reduced order model routines, which are
+libROM: separable to the high-fidelity physics solvers, into libROM.
+libROM:
+libROM: