summaryrefslogtreecommitdiffstats
path: root/libraries/imlib2/imlib2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/imlib2/imlib2.SlackBuild')
-rw-r--r--libraries/imlib2/imlib2.SlackBuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/libraries/imlib2/imlib2.SlackBuild b/libraries/imlib2/imlib2.SlackBuild
index a270604db4..861e589ea3 100644
--- a/libraries/imlib2/imlib2.SlackBuild
+++ b/libraries/imlib2/imlib2.SlackBuild
@@ -1,6 +1,8 @@
#!/bin/sh
# Slackware build script for imlib2
+# Ryan P.C. McQuen | Everett, WA | ryan.q@linux.com
+
# Copyright 2006-2009 Chess Griffin <chess@chessgriffin.com>
# Copyright 2011 Grigorios Bouzakis <grbzks@imap.cc>
# All rights reserved.
@@ -21,7 +23,7 @@
# THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=imlib2
-VERSION=${VERSION:-1.4.6}
+VERSION=${VERSION:-1.4.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -64,10 +66,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
if ! grep -q "my_libs" configure.ac 2>/dev/null; then
sed -i 's|@my_libs@||' $PRGNAM-config.in