summaryrefslogtreecommitdiffstats
path: root/libraries/hypre/hypre.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/hypre/hypre.SlackBuild')
-rw-r--r--libraries/hypre/hypre.SlackBuild171
1 files changed, 171 insertions, 0 deletions
diff --git a/libraries/hypre/hypre.SlackBuild b/libraries/hypre/hypre.SlackBuild
new file mode 100644
index 0000000000..8ea06b7c04
--- /dev/null
+++ b/libraries/hypre/hypre.SlackBuild
@@ -0,0 +1,171 @@
+#!/bin/bash
+
+# Slackware build script for hypre
+
+# Copyright 2022 William PC, Seattle (USA)
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=hypre
+VERSION=${VERSION:-2.26.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+if [ "${OMP:-no}" == "yes" ]; then
+ OPT_BUILD="--with-openmp"
+fi
+
+if [ "${MPI:-no}" == "yes" ]; then
+ OPT_BUILD="$OPT_BUILD --with-MPI"
+else
+ OPT_BUILD="$OPT_BUILD --without-MPI"
+fi
+
+if [ "${CUDA:-no}" == "yes" ]; then
+ OPT_BUILD="$OPT_BUILD --with-cuda"
+fi
+
+if [ "${HIP:-no}" == "yes" ]; then
+ OPT_BUILD="$OPT_BUILD --with-hip"
+fi
+
+# for intel GPU, requires oneMKL
+if [ "${SYCL:-no}" == "yes" ]; then
+ OPT_BUILD="$OPT_BUILD --with-sycl"
+fi
+
+
+# fix building with openmp
+# "undefined reference "omp_get_max""
+# if user sets CFLAGS and CXXFLAGS to configure,
+# the Makefile use these flags and doesn't include
+# the fopenmp
+sed -i '1616aif test "$hypre_using_openmp" = "yes" \
+then \
+ LDFLAGS+=" -fopenmp" \
+fi\n' src/config/configure.in
+
+cd src
+autoconf config/configure.in > configure
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --mandir=/usr/man \
+ --htmldir=/usr/doc/$PRGNAM-$VERSION \
+ --pdfdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-shared \
+ --with-blas \
+ --with-blas-libs=blas \
+ --with-blas-lib-dirs=/usr/lib${LIBDIRSUFFIX} \
+ --with-lapack \
+ --with-lapack-libs=lapack \
+ --with-lapack-lib-dirs=/usr/lib${LIBDIRSUFFIX} \
+ $OPT_BUILD \
+ --host=$(hostname) \
+ --build=$ARCH-slackware-linux
+make
+make test check
+make install HYPRE_LIB_INSTALL=$PKG/usr/lib${LIBDIRSUFFIX} HYPRE_INC_INSTALL=$PKG/usr/include/$PRGNAM
+cd ..
+
+# install examples
+mkdir -p $PKG/usr/share/$PRGNAM-$VERSION
+cp -a src/examples $PKG/usr/share/$PRGNAM-$VERSION
+
+# fix examples
+sed -i -e 's#^HYPRE_DIR = .*#HYPRE_DIR = /usr#' \
+ -e 's#$(HYPRE_DIR)/include#&/hypre#' \
+ -e 's#$[{(]HYPRE_DIR[})]/lib#&'${LIBDIRSUFFIX}'#' \
+ $PKG/usr/share/$PRGNAM-$VERSION/examples/Makefile
+
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG COPYRIGHT LICENSE-APACHE LICENSE-MIT NOTICE SUPPORT.md src/docs \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE