summaryrefslogtreecommitdiffstats
path: root/libraries/html5lib/html5lib.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/html5lib/html5lib.SlackBuild')
-rw-r--r--libraries/html5lib/html5lib.SlackBuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/libraries/html5lib/html5lib.SlackBuild b/libraries/html5lib/html5lib.SlackBuild
index 7b1fcac74b..fa754e8b25 100644
--- a/libraries/html5lib/html5lib.SlackBuild
+++ b/libraries/html5lib/html5lib.SlackBuild
@@ -1,8 +1,10 @@
#!/bin/bash
# Slackware build script for html5lib
-# Written by Šime Ramov <s@ramov.com>
+
+# Copyright 2023 Steven Voges <Oregon, USA>
# Copyright 2017-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Written by Šime Ramov <s@ramov.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +27,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=html5lib
-VERSION=${VERSION:-1.0.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -65,14 +64,16 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ *.rst LICENSE PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install