summaryrefslogtreecommitdiffstats
path: root/libraries/html5lib/html5lib.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/html5lib/html5lib.SlackBuild')
-rw-r--r--libraries/html5lib/html5lib.SlackBuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/libraries/html5lib/html5lib.SlackBuild b/libraries/html5lib/html5lib.SlackBuild
index e04b45d0b3..8195587882 100644
--- a/libraries/html5lib/html5lib.SlackBuild
+++ b/libraries/html5lib/html5lib.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for html5lib
# Written by Šime Ramov <s@ramov.com>
-# Copyright 2017 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2017-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=html5lib
-VERSION=${VERSION:-0.999999999}
+VERSION=${VERSION:-1.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -50,13 +50,16 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGES.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild