summaryrefslogtreecommitdiffstats
path: root/libraries/gtkextra/gtkextra.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/gtkextra/gtkextra.SlackBuild')
-rw-r--r--libraries/gtkextra/gtkextra.SlackBuild48
1 files changed, 28 insertions, 20 deletions
diff --git a/libraries/gtkextra/gtkextra.SlackBuild b/libraries/gtkextra/gtkextra.SlackBuild
index 47c305bded..01d9369354 100644
--- a/libraries/gtkextra/gtkextra.SlackBuild
+++ b/libraries/gtkextra/gtkextra.SlackBuild
@@ -3,16 +3,33 @@
# Slackware build script for gtkextra
# A set of extra widgets for GTK+
-# Written by Niels Horn <niels.horn@gmail.com>
-# Revision date: 2011/03/09
+# Copyright 2010-2011,2013 Niels Horn, Rio de Janeiro, Brazil
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Revision date: 2013/03/30
PRGNAM=gtkextra
-VERSION=${VERSION:-2.1.2}
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-3.0.4}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-SRCNAM=gtk+extra
-
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
@@ -45,9 +62,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -55,17 +72,8 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Solve a problem with spaces in gtkextra/Makefile.in
-patch -p1 < $CWD/make382.patch
-
-# Resolve a bug in the code (thanks to the Gentoo people for finding it)
-patch -p1 < $CWD/gtkcolorcombo.patch
-
-# Patch code for gtk >= 2.21 (based on work by the folks from GTKada)
-patch -p1 < $CWD/gtkextra_gtk2.21.patch
-
-# Fix for glib>=2.31.x
-sed -i "s|glib/gunicode\.h|glib.h|" gtkextra/gtkcharsel.c
+# Fix an error creating the html pages
+sed "s/\(db2html\)/\1 -o gtkextra-tutorial/" -i docs/tutorial/Makefile.in
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \