summaryrefslogtreecommitdiffstats
path: root/libraries/gtk-sharp3
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/gtk-sharp3')
-rw-r--r--libraries/gtk-sharp3/README9
-rw-r--r--libraries/gtk-sharp3/gtk-sharp3-nolibdir.patch21
-rw-r--r--libraries/gtk-sharp3/gtk-sharp3.SlackBuild129
-rw-r--r--libraries/gtk-sharp3/gtk-sharp3.info10
-rw-r--r--libraries/gtk-sharp3/slack-desc19
5 files changed, 188 insertions, 0 deletions
diff --git a/libraries/gtk-sharp3/README b/libraries/gtk-sharp3/README
new file mode 100644
index 0000000000..4d7a3cbb9e
--- /dev/null
+++ b/libraries/gtk-sharp3/README
@@ -0,0 +1,9 @@
+Gtk# is a Graphical User Interface Toolkit for mono and .Net. The
+project binds the gtk+ toolkit and assorted GNOME libraries, enabling
+fully native graphical Gnome application development using Mono and
+.Net development frameworks.
+
+Upstream has not had updates since 2014, so this is using a well-
+maintained fork by the GLibSharp team.
+
+This is able to be installed alongside gtk-sharp without conflicts.
diff --git a/libraries/gtk-sharp3/gtk-sharp3-nolibdir.patch b/libraries/gtk-sharp3/gtk-sharp3-nolibdir.patch
new file mode 100644
index 0000000000..43b9594cfb
--- /dev/null
+++ b/libraries/gtk-sharp3/gtk-sharp3-nolibdir.patch
@@ -0,0 +1,21 @@
+diff -up GtkSharp-3.22.2/Source/meson.build.nolibdir GtkSharp-3.22.2/Source/meson.build
+--- GtkSharp-3.22.2/Source/meson.build.nolibdir 2021-07-30 05:34:33.000000000 +0200
++++ GtkSharp-3.22.2/Source/meson.build 2022-08-07 14:27:13.414754013 +0200
+@@ -74,7 +74,7 @@ version_data.set('PACKAGE_VERSION', pkg_
+
+ install_infos = []
+ nuget_infos = []
+-lib_install_dir = join_paths(get_option('libdir'), 'mono', pkg_version)
++lib_install_dir = join_paths(get_option('prefix'), 'lib', 'mono', pkg_version)
+ pkg_install_dir = join_paths(get_option('libdir'), 'pkgconfig')
+ gapi_xml_installdir = join_paths(get_option('datadir'), 'gapi-3.0')
+
+diff -up GtkSharp-3.22.2/Source/parser/meson.build.nolibdir GtkSharp-3.22.2/Source/parser/meson.build
+--- GtkSharp-3.22.2/Source/parser/meson.build.nolibdir 2021-07-30 05:34:33.000000000 +0200
++++ GtkSharp-3.22.2/Source/parser/meson.build 2022-08-07 14:24:57.849163225 +0200
+@@ -1,4 +1,4 @@
+-gapi_installdir = join_paths(get_option('libdir'), 'gapi-3.0')
++gapi_installdir = join_paths(get_option('prefix'), 'lib', 'gapi-3.0')
+ pkg_install_dir = '@0@/pkgconfig'.format(get_option('libdir'))
+
+ gapi_parser = executable('gapi-parser', 'gapi-parser.cs',
diff --git a/libraries/gtk-sharp3/gtk-sharp3.SlackBuild b/libraries/gtk-sharp3/gtk-sharp3.SlackBuild
new file mode 100644
index 0000000000..9682e956ef
--- /dev/null
+++ b/libraries/gtk-sharp3/gtk-sharp3.SlackBuild
@@ -0,0 +1,129 @@
+#!/bin/bash
+
+# Slackware build script for gtk-sharp3
+
+# Copyright 2023 Jeremy Hansen <jebrhansen+SBo@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# 20220422 bkw: Modified by SlackBuilds.org, BUILD=3:
+# - fix doc permissions.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=gtk-sharp3
+SRCNAM=GtkSharp
+VERSION=${VERSION:-3.22.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# Correct outdated references
+sed -i 's|gdk_api_includes|gio_api_includes|' \
+ Source/{gdk,gio,gtk}/generated/meson.build \
+ Source/sample/valtest/generated/meson.build
+
+# Mono packages use /usr/lib regardless of arch
+patch -p 1 < $CWD/gtk-sharp3-nolibdir.patch
+
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ meson .. \
+ --buildtype=release \
+ --infodir=/usr/info \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ -Dinstall=true \
+ -Dstrip=true
+ "${NINJA:=ninja}"
+ DESTDIR=$PKG $NINJA install
+cd ..
+
+# Some packages expect a libcairo-2 library to be here
+# I'm not sure how frequently these folders change, so we will automate it
+APIVER=$(grep ^apiversion Source/meson.build | cut -d\' -f2)
+PUBTOKEN=$(grep assemblyIdentity Source/policy.config.in | cut -d\" -f4)
+ln -s /usr/lib${LIBDIRSUFFIX}/libcairo.so $PKG/usr/lib/mono/gac/cairo-sharp/${APIVER}__${PUBTOKEN}/libcairo-2.dll.so
+
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+install -m0644 \
+ AUTHORS LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/gtk-sharp3/gtk-sharp3.info b/libraries/gtk-sharp3/gtk-sharp3.info
new file mode 100644
index 0000000000..83e0d3c220
--- /dev/null
+++ b/libraries/gtk-sharp3/gtk-sharp3.info
@@ -0,0 +1,10 @@
+PRGNAM="gtk-sharp3"
+VERSION="3.22.2"
+HOMEPAGE="https://www.mono-project.com/docs/gui/gtksharp/"
+DOWNLOAD="https://github.com/GLibSharp/GtkSharp/archive/refs/tags/3.22.2/GtkSharp-3.22.2.tar.gz"
+MD5SUM="e328931e820216e3280bc5c9bdb1f426"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="mono"
+MAINTAINER="Jeremy Hansen"
+EMAIL="jebrhansen+SBo@gmail.com"
diff --git a/libraries/gtk-sharp3/slack-desc b/libraries/gtk-sharp3/slack-desc
new file mode 100644
index 0000000000..a3898d530e
--- /dev/null
+++ b/libraries/gtk-sharp3/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+gtk-sharp3: gtk-sharp3 (GUI toolkit for mono for GTK3)
+gtk-sharp3:
+gtk-sharp3: Gtk# is a Graphical User Interface Toolkit for mono and .Net. The
+gtk-sharp3: project binds the gtk+ toolkit and assorted GNOME libraries, enabling
+gtk-sharp3: fully native graphical Gnome application development using Mono and
+gtk-sharp3: .Net development frameworks.
+gtk-sharp3:
+gtk-sharp3:
+gtk-sharp3:
+gtk-sharp3: Website: https://www.mono-project.com/docs/gui/gtksharp/
+gtk-sharp3: