summaryrefslogtreecommitdiffstats
path: root/libraries/greenlet/greenlet.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/greenlet/greenlet.SlackBuild')
-rw-r--r--libraries/greenlet/greenlet.SlackBuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/libraries/greenlet/greenlet.SlackBuild b/libraries/greenlet/greenlet.SlackBuild
index f74bd5e785..bc620501cc 100644
--- a/libraries/greenlet/greenlet.SlackBuild
+++ b/libraries/greenlet/greenlet.SlackBuild
@@ -2,10 +2,10 @@
# Slackware build script for Greenlet
#
-# $Revision: b7d6e885f8ce $
-# $Date: 2014/01/03 20:11:43 $
+# $Revision: 305928f153da $
+# $Date: 2015/01/21 22:52:29 $
#
-# Copyright 2014 Adis Nezirović <adis_at_linux.org.ba>
+# Copyright (C) 2014-2015 Adis Nezirović <adis_at_linux.org.ba>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=greenlet
-VERSION=${VERSION:-0.4.1}
+VERSION=${VERSION:-0.4.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,7 +57,7 @@ else
LIBDIRSUFFIX=""
fi
-set -e
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -70,18 +70,15 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-# Strip binaries and libraries.
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS NEWS README.rst doc/greenlet.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS NEWS README.rst doc/greenlet.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install