summaryrefslogtreecommitdiffstats
path: root/libraries/fltk2/fltk2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/fltk2/fltk2.SlackBuild')
-rw-r--r--libraries/fltk2/fltk2.SlackBuild45
1 files changed, 17 insertions, 28 deletions
diff --git a/libraries/fltk2/fltk2.SlackBuild b/libraries/fltk2/fltk2.SlackBuild
index 8d21ecb682..2b74b682f4 100644
--- a/libraries/fltk2/fltk2.SlackBuild
+++ b/libraries/fltk2/fltk2.SlackBuild
@@ -1,32 +1,14 @@
#!/bin/sh
-
-# Slackware build script for fltk, version 2
-
-# The script is based on the build script for FLTK, version 1, by LukenShiro.
-# The script has been fixed by the SlackBuilds.org team.
-
-# Copyright 2009-2010 Mikhail Zotov <mikhail dot ru@gmail dot com>
-# All rights reserved.
#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
+# Slackware build script for fltk, version 2
#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
+# Maintainer of the script: Mikhail Zotov <mikhail dot ru@gmail dot com>
#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# The script is based on the build script for FLTK, version 1, by LukenShiro.
+# The script has been fixed by the SlackBuilds.org team.
PRGNAM=fltk2
-VERSION=2.0.x_r7513
+VERSION=2.0.x_r8365
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,13 +53,20 @@ rm -rf $SRC_PRGNAM-$SRC_VERSION
tar xvf $CWD/$SRC_PRGNAM-$SRC_VERSION.tar.bz2
cd $SRC_PRGNAM-$SRC_VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
# Fix linking when --libdir=/usr/lib64
sed -i \
-e '/RANLIB/s:$(libdir)/\(.*LIBNAME)\):$(libdir)/`basename \1`:g' \
src/Makefile || exit
+# Make building more "verbose"
+sed -i 's/\.SILENT://' makeinclude.in
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -86,18 +75,18 @@ CXXFLAGS="$SLKCFLAGS" \
--mandir=/usr/man \
--enable-shared
-make
+make VERBOSE=1
make install DESTDIR=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-# No manpages are installed
+# Remove empty directories since no manual pages are installed
rm -rf $PKG/usr/man
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/
cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/fltk2.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/fltk2.SlackBuild
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc