summaryrefslogtreecommitdiffstats
path: root/libraries/bcdoc/bcdoc.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/bcdoc/bcdoc.SlackBuild')
-rw-r--r--libraries/bcdoc/bcdoc.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/libraries/bcdoc/bcdoc.SlackBuild b/libraries/bcdoc/bcdoc.SlackBuild
index f8743fd3cf..34642d6f94 100644
--- a/libraries/bcdoc/bcdoc.SlackBuild
+++ b/libraries/bcdoc/bcdoc.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for bcdoc
-# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2020 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=bcdoc
VERSION=${VERSION:-0.16.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,7 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true