summaryrefslogtreecommitdiffstats
path: root/libraries/bamf
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/bamf')
-rw-r--r--libraries/bamf/add_compile_warning_flags.patch71
-rw-r--r--libraries/bamf/bamf.SlackBuild6
-rw-r--r--libraries/bamf/bamf.info2
3 files changed, 77 insertions, 2 deletions
diff --git a/libraries/bamf/add_compile_warning_flags.patch b/libraries/bamf/add_compile_warning_flags.patch
new file mode 100644
index 0000000000..203ccc75d3
--- /dev/null
+++ b/libraries/bamf/add_compile_warning_flags.patch
@@ -0,0 +1,71 @@
+https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=940164
+
+diff -Naur bamf-0.5.4.orig/configure.ac bamf-0.5.4/configure.ac
+--- bamf-0.5.4.orig/configure.ac 2018-11-07 23:39:11.355315678 +0100
++++ bamf-0.5.4/configure.ac 2019-11-18 12:57:04.534000000 +0100
+@@ -18,14 +18,15 @@
+ GNOME_COMPILE_WARNINGS(maximum)
+
+ AM_MAINTAINER_MODE
+-AM_DISABLE_STATIC
+-AM_PROG_LIBTOOL
+ AC_ISC_POSIX
+ AC_SUBST(ACLOCAL_AMFLAFS, "$ACLOCAL_FLAGS -I m4")
+
+ PKG_PROG_PKG_CONFIG
+ if test "x$PKG_CONFIG" = "x"; then AC_MSG_ERROR([You need to install pkg-config]); fi
+
++LT_INIT([disable-static])
++LT_LIB_M
++
+ # Checks for programs.
+ AC_PROG_CC
+ AM_PROG_CC_C_O
+@@ -154,8 +155,39 @@
+ #
+ AM_PATH_GTK_3_0
+
++# Compile warnings
++AC_ARG_ENABLE(compile-warnings,
++ AS_HELP_STRING([--enable-compile-warnings=@<:@no/minimum/yes/maximum/error@:>@],
++ [Trun on compiler warnings]),,
++ [enable_compile_warnings=maximum])
++
++warning_flags=
++
++case "$enable_compile_warnings" in
++no)
++warning_flags=
++;;
++minimum)
++warning_flags="-Wall"
++;;
++yes)
++warning_flags="-wall -Wno-error=deprecated-declarations"
++;;
++maximum|error)
++warning_flags="-Wall -Wno-error=deprecated-declarations -Wempty-body -Wformat-security -Winit-self -Warray-bounds -Wimplicit-function-declaration"
++if test "$enable_compile_warnings" = "error" ; then
++ warning_flags="$warning_flags -Werror"
++fi
++;;
++*)
++AC_MSG_ERROR(Unknown argument '$enable_compile_warnings' to --enable-compile-warnings)
++;;
++esac
++AC_MSG_CHECKING(what warning flags to pass to the C compiler)
++AC_MSG_RESULT($warning_flags)
++
+ dnl CFLAGS
+-CFLAGS="$CFLAGS -Wall -Werror -Wno-error=deprecated-declarations -Wempty-body -Wformat-security -Winit-self -Warray-bounds -Wimplicit-function-declaration -lm"
++CFLAGS="$CFLAGS $warning_flags $LIBM"
+
+ AC_SUBST(BAMFDAEMON_CFLAGS)
+ AC_SUBST(BAMFDAEMON_LIBS)
+@@ -190,5 +222,6 @@
+ Headless tests: ${enable_headless_tests}
+ Coverage Reporting: ${use_gcov}
+ Export actions menus: ${enable_export_actions_menu}
++ Compiler Flags: ${CFLAGS}
+
+ EOF
diff --git a/libraries/bamf/bamf.SlackBuild b/libraries/bamf/bamf.SlackBuild
index c950ae1115..0a12d2f802 100644
--- a/libraries/bamf/bamf.SlackBuild
+++ b/libraries/bamf/bamf.SlackBuild
@@ -70,6 +70,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch -p1 < $CWD/add_compile_warning_flags.patch
+autoreconf -vif
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -79,7 +82,8 @@ CXXFLAGS="$SLKCFLAGS" \
--localstatedir=/var \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
- --disable-introspection \
+ --enable-introspection \
+ --enable-compile-warnings=no \
--build=$ARCH-slackware-linux
make
diff --git a/libraries/bamf/bamf.info b/libraries/bamf/bamf.info
index af9621ea49..600d9355a9 100644
--- a/libraries/bamf/bamf.info
+++ b/libraries/bamf/bamf.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://launchpad.net/bamf/0.5/0.5.4/+download/bamf-0.5.4.tar.gz"
MD5SUM="e5078ec8f6c8a9d77242010dcd3b3217"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="libgtop libwnck3"
+REQUIRES="gnome-common libgtop libwnck3"
MAINTAINER="Donald Cooley"
EMAIL="chytraeus@protonmail.com"