summaryrefslogtreecommitdiffstats
path: root/libraries/aubio/aubio.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/aubio/aubio.SlackBuild')
-rw-r--r--libraries/aubio/aubio.SlackBuild41
1 files changed, 26 insertions, 15 deletions
diff --git a/libraries/aubio/aubio.SlackBuild b/libraries/aubio/aubio.SlackBuild
index fda64ed90b..5b0941a2bb 100644
--- a/libraries/aubio/aubio.SlackBuild
+++ b/libraries/aubio/aubio.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for aubio
-# Copyright 2008-2011 Heinz Wiesinger, Amsterdam, The Netherlands
+# Copyright 2008-2016 Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=aubio
-VERSION=0.3.2
-BUILD=${BUILD:-3}
+VERSION=0.4.2
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -60,7 +60,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -69,29 +69,40 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-LDFLAGS="-lm" \
+# Fix detecting ffmpeg
+sed -i "s|'HAVE_' + i in ctx.env.define_key|'HAVE_' + i in ctx.env|" \
+ wscript
+
+# Fix the build system...
+sed -i "s|'\${PREFIX}' + '/share/doc/libaubio-doc'|'\${DOCDIR}'|" wscript
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
-./configure \
+./waf configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
- --disable-static \
- --build=$ARCH-slackware-linux \
- --host=$ARCH-slackware-linux
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-fftw3f
-make
-make install-strip DESTDIR=$PKG
+./waf build
-mkdir -p $PKG/usr/man/man1
-cp -f doc/*.1 $PKG/usr/man/man1/
+./waf install \
+ --destdir=$PKG
+
+if ! [ "${BINDINGS:-no}" = "no" ]; then
+ cd python
+ python setup.py install --root=$PKG
+ cd ..
+fi
-find $PKG/usr/man -type f -exec gzip -9 {} \;
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS ChangeLog COPYING INSTALL NEWS README THANKS TODO VERSION \
+cp -a AUTHORS ChangeLog COPYING README.md VERSION \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild