summaryrefslogtreecommitdiffstats
path: root/libraries/VTK/VTK.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/VTK/VTK.SlackBuild')
-rw-r--r--libraries/VTK/VTK.SlackBuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/libraries/VTK/VTK.SlackBuild b/libraries/VTK/VTK.SlackBuild
index ae29a67c07..7fa81dd1b8 100644
--- a/libraries/VTK/VTK.SlackBuild
+++ b/libraries/VTK/VTK.SlackBuild
@@ -96,6 +96,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Build with libfreetype-2.10.3 and higher patch courtesy of
+# https://bugs.archlinux.org/task/68291#comments
+# also upstream at https://gitlab.kitware.com/vtk/vtk/-/issues/18033
+patch -p1 < $CWD/vtk-freetype-2.10.3-provide-FT_CALLBACK_DEF.patch
+
+sed -i '/include <QTextStream>/a #include <QPainterPath>' \
+ Rendering/Qt/vtkQtLabelRenderStrategy.cxx \
+ Rendering/Qt/vtkQtStringToImage.cxx
+
if pkg-config --exists proj ; then
proj="-DVTK_USE_SYSTEM_LIBPROJ:BOOL=ON"
# proj6 patch courtesy of
@@ -105,6 +114,11 @@ else
proj=""
fi
+# https://github.com/archlinux/svntogit-community/blob/packages/vtk/trunk/PKGBUILD
+( cd ThirdParty/exodusII/vtkexodusII
+ patch -p1 < $CWD/patch-gcc10.diff )
+sed -i 's|REGEX MATCH \"\[3-9\]|REGEX MATCH \"[1-9][0-9]|' CMake/VTKGenerateExportHeader.cmake
+
mkdir -p build
cd build
cmake \