summaryrefslogtreecommitdiffstats
path: root/graphics/xdot/xdot.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/xdot/xdot.SlackBuild')
-rw-r--r--graphics/xdot/xdot.SlackBuild17
1 files changed, 3 insertions, 14 deletions
diff --git a/graphics/xdot/xdot.SlackBuild b/graphics/xdot/xdot.SlackBuild
index 471ab8c6c9..139343e5af 100644
--- a/graphics/xdot/xdot.SlackBuild
+++ b/graphics/xdot/xdot.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for xdot
#
# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
-# Copyright 2015-2021 Kyle Guinn <elyk03@gmail.com>
+# Copyright 2015-2024 Kyle Guinn <elyk03@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=xdot
SRCNAM=xdot.py
-VERSION=${VERSION:-1.2}
+VERSION=${VERSION:-1.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,16 +40,13 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM-$VERSION
+PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
DOCS="LICENSE.txt README.md sample.py"
@@ -65,14 +62,6 @@ cd $SRCNAM-$VERSION
chown -R root:root .
chmod -R u+w,go-w,a+rX-st .
-# xdot expects named tuples to be returned by some GDK functions, else it
-# spams stderr with stack traces. Likely changed in version 3.19.1 of
-# pygobject3-python3, but SBo is still on 3.18.2. Use regular tuples for now.
-sed -i \
- -e 's/pointer.x/pointer[1]/' \
- -e 's/pointer.y/pointer[2]/' \
- xdot/ui/actions.py
-
python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION