summaryrefslogtreecommitdiffstats
path: root/graphics/vimiv-qt/vimiv-qt.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/vimiv-qt/vimiv-qt.SlackBuild')
-rw-r--r--graphics/vimiv-qt/vimiv-qt.SlackBuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/graphics/vimiv-qt/vimiv-qt.SlackBuild b/graphics/vimiv-qt/vimiv-qt.SlackBuild
index 4540b51bde..d090781937 100644
--- a/graphics/vimiv-qt/vimiv-qt.SlackBuild
+++ b/graphics/vimiv-qt/vimiv-qt.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for vimiv-qt
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=vimiv-qt
-VERSION=${VERSION:-0.8.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-0.9.0}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -79,7 +76,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# Install man files to /usr/man, rather than /usr/share/man
+sed -i "s/\$(DATADIR)\\/man/\$(DESTDIR)\\/\$(PREFIX)\\/man/g" misc/Makefile
+
+# Do not install license files to /usr/share/licenses
+sed -i "/LICENSEDIR/d" misc/Makefile
+
+make -f misc/Makefile DESTDIR=$PKG install
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -90,6 +93,7 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE