summaryrefslogtreecommitdiffstats
path: root/graphics/tuxpaint
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/tuxpaint')
-rw-r--r--graphics/tuxpaint/README7
-rw-r--r--graphics/tuxpaint/tuxpaint.SlackBuild59
-rw-r--r--graphics/tuxpaint/tuxpaint.info12
-rw-r--r--graphics/tuxpaint/tuxpaint_SDL2_Pango.patch19
4 files changed, 18 insertions, 79 deletions
diff --git a/graphics/tuxpaint/README b/graphics/tuxpaint/README
index 8d4a427dac..9efd841a1c 100644
--- a/graphics/tuxpaint/README
+++ b/graphics/tuxpaint/README
@@ -8,10 +8,3 @@ a very limited tool-set. However, it provides a much simpler interface,
and has entertaining, child-oriented additions such as sound effects.
tuxpaint-config is now also included as a gui tool to configure
tuxpaint.
-
-Note: Please uninstall inkscape before creating this package if you
-want to avoid a couple of file artifacts outside the package directory.
-inkscape can be reinstalled once this package is created.
-This is the sdl2 version of the program. Note: dependencies have changed
-note: this build update (3) is needed for using SDL2_Pango>0.9.0
-
diff --git a/graphics/tuxpaint/tuxpaint.SlackBuild b/graphics/tuxpaint/tuxpaint.SlackBuild
index 6bc864e373..bd19add0de 100644
--- a/graphics/tuxpaint/tuxpaint.SlackBuild
+++ b/graphics/tuxpaint/tuxpaint.SlackBuild
@@ -4,23 +4,19 @@
# Written by Pablo Santamaria (pablosantamaria@gmail.com)
# Modified by Willy Sudiarto Raharjo <willysr@slackware-id.org>
-# Taken over maintenance (and some updates) by Tim Dickson (dickson.tim@googlemail.com)
+# re-written by Tim Dickson (dickson.tim@googlemail.com)
# added tuxpaint-config 2019-02-11
-# 20220222 bkw: Modified by SlackBuilds.org: fix build on 15.0.
-# - update for v0.9.27 and config v0.0.18.
-# - fix parallel builds.
-# - stop spamming the real /usr (ugh).
-# 20220610 tim dickson: updated to 0.9.28 . sticking with sdl1 version for now
-# 20220629 tim dickson: changed to the sdl2 version
-# 20220820 tim dickson: added patch to work with newer SDL2_Pango. should be fixed upstream in next release
+# previous update history cleaned out.
+# 29239721 tun: update to 0.9.31 and 0.0.22 (fixed upstream makefile)
+# 2024/01/29: bump version to 0.9.32 and config to 0.0.23
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=tuxpaint
-VERSION=${VERSION:-0.9.28}
-CONFVER=${CONFVER:-0.0.19}
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-0.9.32}
+CONFVER=${CONFVER:-0.0.23}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -60,12 +56,10 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION-sdl2
+rm -rf $PRGNAM-$VERSION
rm -rf $PRGNAM-config-$CONFVER
-tar xvf $CWD/$PRGNAM-$VERSION-sdl2.tar.gz
-cd $PRGNAM-$VERSION-sdl2
-#prevent out-of-tree file if inkscape is installed
-export INKSCAPE_PROFILE_DIR=${pwd}/.tmp.inkscape
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -73,19 +67,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-# 20220226 bkw: fix parallel builds.
-mkdir trans
-
-# 20220226 bkw: FFS, do NOT attempt to install icons and .desktop
-# using the xdg-icon-resource and xdg-desktop-menu tools: these don't
-# support DESTDIR or any other way to control where the files get
-# installed (meaning they install to the real /usr, not $PKG/usr).
-
-#patch to fix working with newer SDL2_Pango. remove for next version update
-patch <$CWD/tuxpaint_SDL2_Pango.patch
-
-sed -i '/^linux_ARCH_INSTALL/s,install-xdg ,,' Makefile
-
make PREFIX=/usr LIBDIRSUFFIX=$LIBDIRSUFFIX OPTFLAGS="$SLKCFLAGS"
make \
MAN_PREFIX=$PKG/usr/man \
@@ -94,23 +75,11 @@ make \
DEVDOC_PREFIX=$PKG/usr/doc/$PRGNAM-$VERSION \
PREFIX=/usr \
LIBDIRSUFFIX=$LIBDIRSUFFIX \
+ PACKAGE_ONLY=yes \
DESTDIR=$PKG \
install
mv $PKG/etc/tuxpaint/tuxpaint.conf $PKG/etc/tuxpaint/tuxpaint.conf.new
-mkdir -p $PKG/usr/share/applications
-cp src/$PRGNAM.desktop $PKG/usr/share/applications/
-
-# 20220226 bkw: install the icons correctly, to $PKG. Not only were
-# they going to the real /usr, they were incorrectly named!
-for i in data/images/icon*x*.png; do
- px="$( basename $i | cut -dx -f2 | cut -d. -f1 )"
- size=${px}x${px}
- dir=$PKG/usr/share/icons/hicolor/$size/apps
- mkdir -p $dir
- cp -a $i $dir/$PRGNAM.png
-done
-
#
#now for tuxpaint-config
#
@@ -118,11 +87,6 @@ cd ..
tar xvf $CWD/$PRGNAM-config-$CONFVER.tar.gz
cd $PRGNAM-config-$CONFVER
-# 20220226 bkw: fix parallel builds.
-mkdir trans
-#fix X11 location
-sed -i 's_X11R6/i_/i_g' Makefile
-
make PREFIX=/usr LIBDIRSUFFIX=$LIBDIRSUFFIX OPTFLAGS="$SLKCFLAGS"
make \
MAN_PREFIX=/usr/man \
@@ -140,6 +104,7 @@ chmod 0644 $PKG/usr/man/*/*/tuxpaint.1.gz
chmod 0644 $PKG/usr/man/man1/*.gz
find $PKG/usr/doc/$PRGNAM-$VERSION/ -type f -exec chmod 644 {} \+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/graphics/tuxpaint/tuxpaint.info b/graphics/tuxpaint/tuxpaint.info
index c89e9609ee..5989c055e5 100644
--- a/graphics/tuxpaint/tuxpaint.info
+++ b/graphics/tuxpaint/tuxpaint.info
@@ -1,10 +1,10 @@
PRGNAM="tuxpaint"
-VERSION="0.9.28"
-HOMEPAGE="http://www.tuxpaint.org"
-DOWNLOAD="http://downloads.sourceforge.net/tuxpaint/tuxpaint-0.9.28-sdl2.tar.gz \
- http://downloads.sourceforge.net/tuxpaint/tuxpaint-config-0.0.19.tar.gz"
-MD5SUM="267cc6280b66bd32d77133e3562f8da4 \
- f732341c88761e756581264960553198"
+VERSION="0.9.32"
+HOMEPAGE="https://tuxpaint.org"
+DOWNLOAD="https://downloads.sourceforge.net/tuxpaint/tuxpaint-0.9.32.tar.gz \
+ https://downloads.sourceforge.net/tuxpaint/tuxpaint-config-0.0.23.tar.gz"
+MD5SUM="f556f36bf71167ce163ac41c6199bac0 \
+ 18ea8151cbb927310f2fab11e34034a0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libpaper SDL2_Pango fltk pngquant libunibreak"
diff --git a/graphics/tuxpaint/tuxpaint_SDL2_Pango.patch b/graphics/tuxpaint/tuxpaint_SDL2_Pango.patch
deleted file mode 100644
index 11011b49fe..0000000000
--- a/graphics/tuxpaint/tuxpaint_SDL2_Pango.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -294,6 +294,7 @@
-
- # SDL Pango is needed to render complex scripts like Thai and Arabic
- SDL2_PANGO_LIB:=$(call linktest,SDL2_Pango,-lSDL2_Pango,$(SDL_LIBS))
-+SDL2_PANGO_CFLAGS:=$(shell $(PKG_CONFIG) --cflags SDL2_Pango)
- NOPANGOFLAG:=$(if $(SDL2_PANGO_LIB),,-DNO_SDLPANGO$(warning -lSDL2_Pango failed, no scripts for you!))
-
- SDL_LIBS+=$(SDL_MIXER_LIB) $(SDL2_PANGO_LIB)
-@@ -341,6 +342,7 @@
- -Waggregate-return \
- -Wstrict-prototypes -Wmissing-prototypes \
- $(shell src/test-option.sh -Wstrict-aliasing=2) \
-+ $(SDL2_PANGO_CFLAGS) \
- $(ARCH_CFLAGS)
-
- DEFS:=-DVER_DATE=\"$(VER_DATE)\" -DVER_VERSION=\"$(VER_VERSION)\" \
-