summaryrefslogtreecommitdiffstats
path: root/graphics/tikzit
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/tikzit')
-rw-r--r--graphics/tikzit/README5
-rw-r--r--graphics/tikzit/doinst.sh14
-rw-r--r--graphics/tikzit/slack-desc19
-rw-r--r--graphics/tikzit/tikzit.SlackBuild96
-rw-r--r--graphics/tikzit/tikzit.info10
5 files changed, 144 insertions, 0 deletions
diff --git a/graphics/tikzit/README b/graphics/tikzit/README
new file mode 100644
index 0000000000..6e275ae77b
--- /dev/null
+++ b/graphics/tikzit/README
@@ -0,0 +1,5 @@
+TikZiT
+
+TikZiT is a graphical tool for rapidly creating graphs and string
+diagrams using PGF/TikZ. It was used, for example, to make all of the
+2500+ diagrams in http://cambridge.org/pqp
diff --git a/graphics/tikzit/doinst.sh b/graphics/tikzit/doinst.sh
new file mode 100644
index 0000000000..262eb5a9e5
--- /dev/null
+++ b/graphics/tikzit/doinst.sh
@@ -0,0 +1,14 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+# If other icon themes are installed, then add to/modify this as needed
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/graphics/tikzit/slack-desc b/graphics/tikzit/slack-desc
new file mode 100644
index 0000000000..0e216ef47f
--- /dev/null
+++ b/graphics/tikzit/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+tikzit: tikzit (a graphical tool for rapidly creating TikZ graphics)
+tikzit:
+tikzit: tikzit is a graphical tool for rapidly creating graphs and string
+tikzit: diagrams using PGF/TikZ.
+tikzit:
+tikzit:
+tikzit:
+tikzit:
+tikzit:
+tikzit:
+tikzit:
diff --git a/graphics/tikzit/tikzit.SlackBuild b/graphics/tikzit/tikzit.SlackBuild
new file mode 100644
index 0000000000..b8a303a0ed
--- /dev/null
+++ b/graphics/tikzit/tikzit.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/bash
+# Slackware build script for tikzit
+# Copyright 2023 Lockywolf Earth
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+PRGNAM=tikzit
+VERSION=${VERSION:-2.1.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+set -e
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -i '/set(SOUR/ifile(GLOB SOURCES src/*.cpp src/data/*.cpp src/gui/*.cpp)' CMakeLists.txt
+sed -i '/set(SOUR/,/)/d' CMakeLists.txt
+sed -i '/set(HEAD/,/)/d' CMakeLists.txt
+mkdir -p build
+(
+cd build
+ qmake PREFIX=/usr \
+ QMAKE_CFLAGS="${SLKCFLAGS}" \
+ QMAKE_CXXFLAGS="${SLKCFLAGS}" -r ..
+ make
+ make INSTALL_ROOT="$PKG" install
+)
+mv $PKG/usr/share/man $PKG/usr
+chmod 644 $PKG/usr/share/applications/tikzit.desktop
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.md COPYING \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/graphics/tikzit/tikzit.info b/graphics/tikzit/tikzit.info
new file mode 100644
index 0000000000..771d7877e1
--- /dev/null
+++ b/graphics/tikzit/tikzit.info
@@ -0,0 +1,10 @@
+PRGNAM="tikzit"
+VERSION="2.1.6"
+HOMEPAGE="https://github.com/tikzit/tikzit"
+DOWNLOAD="https://github.com/tikzit/tikzit/archive/v2.1.6/tikzit-2.1.6.tar.gz"
+MD5SUM="e12715e9571cd256b1a39c54c06f9b5f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo-tikzit_2023-05-07@lockywolf.net"