summaryrefslogtreecommitdiffstats
path: root/graphics/qiv/new_formats.diff
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/qiv/new_formats.diff')
-rw-r--r--graphics/qiv/new_formats.diff46
1 files changed, 19 insertions, 27 deletions
diff --git a/graphics/qiv/new_formats.diff b/graphics/qiv/new_formats.diff
index bc5622fd89..0953a23b67 100644
--- a/graphics/qiv/new_formats.diff
+++ b/graphics/qiv/new_formats.diff
@@ -1,25 +1,22 @@
-diff -Naur qiv-2.3.2/Makefile qiv-2.3.2.patched/Makefile
---- qiv-2.3.2/Makefile 2017-11-03 14:27:27.000000000 -0400
-+++ qiv-2.3.2.patched/Makefile 2019-12-31 14:06:51.304388148 -0500
-@@ -24,7 +24,7 @@
- # skipped.) It should reflect whatever is compiled into imlib.
+diff -Naur qiv-2.3.3/Makefile qiv-2.3.3.patched/Makefile
+--- qiv-2.3.3/Makefile 2023-01-28 16:37:29.000000000 -0500
++++ qiv-2.3.3.patched/Makefile 2023-06-06 02:52:08.518230436 -0400
+@@ -26,7 +26,7 @@
+ # or is compiled into imlib.
# The latest version of imlib has removed imagemagick fallback support,
# so some extensions (XBM TGA) have been removed.
--EXTNS = GIF TIFF XPM PNG PPM PNM PGM PCX BMP EIM JPEG SVG WMF ICO
-+EXTNS = GIF TIFF XPM PNG PPM PNM PGM PCX BMP EIM JPEG SVG WMF ICO WEBP XCF PSD ICNS TGA RAW
+-EXTNS = GIF TIFF XPM PNG PPM PNM PGM PCX BMP EIM JPEG SVG WMF ICO WEBP HEIF
++EXTNS = GIF TIFF XPM PNG PPM PNM PGM PCX BMP EIM JPEG SVG WMF ICO WEBP HEIF XCF PSD ICNS TGA RAW JP2
# Comment this line out if your system doesn't have getopt_long().
GETOPT_LONG = -DHAVE_GETOPT_LONG
-diff -Naur qiv-2.3.2/main.h qiv-2.3.2.patched/main.h
---- qiv-2.3.2/main.h 2017-11-03 14:27:27.000000000 -0400
-+++ qiv-2.3.2.patched/main.h 2019-12-31 14:27:29.455909124 -0500
-@@ -199,6 +199,27 @@
- #ifdef EXTN_SVG
- ".svg",
+diff -Naur qiv-2.3.3/main.h qiv-2.3.3.patched/main.h
+--- qiv-2.3.3/main.h 2023-01-28 16:37:29.000000000 -0500
++++ qiv-2.3.3.patched/main.h 2023-06-06 02:58:13.422196095 -0400
+@@ -211,6 +211,21 @@
+ #ifdef EXTN_HEIF
+ ".heic", ".heif",
#endif
-+#ifdef EXTN_WEBP
-+ ".webp",
-+#endif
+#ifdef EXTN_XCF
+ ".xcf",
+#endif
@@ -29,25 +26,19 @@ diff -Naur qiv-2.3.2/main.h qiv-2.3.2.patched/main.h
+#ifdef EXTN_ICNS
+ ".icns",
+#endif
-+ /* BROKEN in slackware 14.2, using newer versions
-+ of jasper and gdk-pixbuf2 built with jasper didn't help.
-+ Disabled in Makefile. */
+#ifdef EXTN_JP2
+ ".jp2", ".jpc", ".jpx", ".j2k", ".jpf",
+#endif
+#ifdef EXTN_RAW
-+ "dng", "cr2", "crw", "nef", "orf", "pef", "arw", "erf", "mrw", "raf",
++ ".dng", ".cr2", ".crw", ".nef", ".orf", ".pef", ".arw", ".erf", ".mrw", ".raf",
+#endif
NULL
};
-@@ -238,6 +259,29 @@
- #ifdef EXTN_ICO
- "MS Windows icon resource",
+@@ -256,6 +271,27 @@
+ #ifdef EXTN_HEIF
+ "ISO Media, HEIF Image",
#endif
-+#ifdef EXTN_WEBP
-+ "RIFF (little-endian) data, Web/P image",
-+#endif
+#ifdef EXTN_XCF
+ "GIMP XCF image data",
+#endif
@@ -62,7 +53,8 @@ diff -Naur qiv-2.3.2/main.h qiv-2.3.2.patched/main.h
+#endif
+#ifdef EXTN_RAW
+ /* 20191231 bkw: some of these (dng, nef, erf, pef) show up as TIFF
-+ with the file command, so we can't include them here. */
++ with the file command, so we can't include them here. cr3 is "ISO Media",
++ which fails to work if added here. */
+ "Canon CIFF",
+ "Canon CR2",
+ "Olympus ORF",