summaryrefslogtreecommitdiffstats
path: root/graphics/qcomicbook/qcomicbook.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/qcomicbook/qcomicbook.SlackBuild')
-rw-r--r--graphics/qcomicbook/qcomicbook.SlackBuild70
1 files changed, 41 insertions, 29 deletions
diff --git a/graphics/qcomicbook/qcomicbook.SlackBuild b/graphics/qcomicbook/qcomicbook.SlackBuild
index c863fb1248..eada94d7a0 100644
--- a/graphics/qcomicbook/qcomicbook.SlackBuild
+++ b/graphics/qcomicbook/qcomicbook.SlackBuild
@@ -3,9 +3,10 @@
# Slackware build script for QComicBook:
# a program to visualize digitalized comic books
-# Original version written by Amiralul - tanaselia@gmail.com
+# Original version written by Amiralul (email removed)
# Copyright 2009-2012 Niels Horn, Rio de Janeiro, RJ, Brazil
+# Copyright 2023 B. Watson
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,14 +26,20 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# revision date 2012/07/23
+# 20230418 bkw: BUILD=2
+# - new maintainer.
+# - move icon to /usr/share/icons (and symlink to pixmaps).
+# - make .desktop file validate with no warnings.
+# - replace README and slack-desc with something more descriptive.
+# - make unrar optional.
+# - document unrar and other decompressors in README.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=qcomicbook
SRCNAM=QComicBook
VERSION=${VERSION:-0.9.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -55,16 +62,12 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
fi
set -e
@@ -76,39 +79,48 @@ rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \+ -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-# Icon info in the desktop file should not have a file extension
-sed -i 's/\.png$//' data/qcomicbook.desktop
+# 20230418 bkw: install man pages and icon in right places.
+sed -i 's,share/man,man,' help/CMakeLists.txt
+sed -i 's,pixmaps,icons/hicolor/48x48/apps,' data/CMakeLists.txt
-# Remove the iCCP chunk from the PNG images to avoid warnings
+# Icon info in the desktop file should not have a file extension.
+# 20230418 bkw: also, remove deprecated stuff.
+sed -i -e 's/\.png$//' \
+ -e 's,Application;,,' \
+ -e '/^Encoding/d' \
+ data/qcomicbook.desktop
+
+# Remove the iCCP chunk from the PNG images to avoid warnings.
for i in data/*.png; do
mv $i $i.old.png
convert $i.old.png $i
rm $i.old.png
done
-cmake . \
- -DCMAKE_CXX_FLAGS_RELEASE:STRING="$SLKCFLAGS -DNDEBUG" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release
+mkdir build
+cd build
+ cmake .. \
+ -DCMAKE_CXX_FLAGS_RELEASE="$SLKCFLAGS -DNDEBUG" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+
+ make VERBOSE=1
+ make install/strip DESTDIR=$PKG
+cd -
-make VERBOSE=1
-make install/strip DESTDIR=$PKG
+gzip $PKG/usr/man/man*/*
-# Move manpage to correct location and gzip them
-mv $PKG/usr/share/man $PKG/usr/man
-gzip -9 $PKG/usr/man/man1/$PRGNAM.1
+mkdir -p $PKG/usr/share/pixmaps
+ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS COPYING ChangeLog README THANKS TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION/
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# NEWS is a 0-byte placeholder, do not package.
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+cp -a AUTHORS COPYING ChangeLog README THANKS TODO $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc