summaryrefslogtreecommitdiffstats
path: root/graphics/pngquant/pngquant.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/pngquant/pngquant.SlackBuild')
-rw-r--r--graphics/pngquant/pngquant.SlackBuild13
1 files changed, 3 insertions, 10 deletions
diff --git a/graphics/pngquant/pngquant.SlackBuild b/graphics/pngquant/pngquant.SlackBuild
index baa0a1d5a2..7222682f99 100644
--- a/graphics/pngquant/pngquant.SlackBuild
+++ b/graphics/pngquant/pngquant.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pngquant
-# Copyright 2013 Kyle Guinn <elyk03@gmail.com>, USA
+# Copyright 2013-2014 Kyle Guinn <elyk03@gmail.com>, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pngquant
-VERSION=${VERSION:-2.0.1}
+VERSION=${VERSION:-2.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -65,14 +65,7 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION-src.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Remove unnecessary '-$(MAKEFLAGS)' in Makefiles.
-sed -i 's/-\$(MAKEFLAGS)//g' Makefile lib/Makefile
+chmod -R u+w,go-w,a+rX-st .
make CFLAGSADD="$SLKCFLAGS"
install -D -m0755 -s pngquant $PKG/usr/bin/pngquant