summaryrefslogtreecommitdiffstats
path: root/graphics/mcomix/mcomix.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/mcomix/mcomix.SlackBuild')
-rw-r--r--graphics/mcomix/mcomix.SlackBuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/graphics/mcomix/mcomix.SlackBuild b/graphics/mcomix/mcomix.SlackBuild
index 5a05d2dae4..2c2d25dbab 100644
--- a/graphics/mcomix/mcomix.SlackBuild
+++ b/graphics/mcomix/mcomix.SlackBuild
@@ -6,6 +6,7 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20231124 bkw: update for v3.0.0.
# 20230905 bkw: update for v2.3.0
# 20230822 bkw: update for v2.2.1.
# 20230625 bkw: update for v2.1.1.
@@ -23,7 +24,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mcomix
-VERSION=${VERSION:-2.3.0}
+VERSION=${VERSION:-3.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -62,12 +63,19 @@ chown -R root:root .
find . -type f -a -exec chmod 644 {} + -o \
-type d -a -exec chmod 755 {} +
-sed -i 's,share/man,man,g' setup.py
-python3 setup.py install --root=$PKG
+export PYTHONPATH=/opt/python3.9/site-packages
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
+
+# 20231124 bkw: 3.0.0 ships this stuff but doesn't install it like
+# the 2.x series did.
+mv share/man man
+cp -a share man $PKG/usr
# 20230905 bkw: 2.2.1 has good icons. The ones in 2.3.0 are wrong-sized,
# e.g. the "32x32" one is actually 32x24. So I made a tarball of the old
# icons... which didn't include the giant 256x256 one.
+# 20231124 bkw: 3.0.0 icons are still b0rked.
rm -rf $PKG/usr/share/icons/hicolor/256x256
( cd $PKG ; tar xvf $CWD/mcomix-good-icons.tar.xz )
mkdir -p $PKG/usr/share/pixmaps
@@ -77,7 +85,7 @@ ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKGDOC
-cp -a COPYING README ChangeLog $PKGDOC
+cp -a COPYING README* ChangeLog* $PKGDOC
cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install