summaryrefslogtreecommitdiffstats
path: root/graphics/libplacebo/libplacebo.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/libplacebo/libplacebo.SlackBuild')
-rw-r--r--graphics/libplacebo/libplacebo.SlackBuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/graphics/libplacebo/libplacebo.SlackBuild b/graphics/libplacebo/libplacebo.SlackBuild
index 87133eddc8..ddda6f8e38 100644
--- a/graphics/libplacebo/libplacebo.SlackBuild
+++ b/graphics/libplacebo/libplacebo.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for libplacebo
# Copyright 2019-2020 Hunter Sezen California, USA
+# Copyright 2023 Christoph Willing Brisbane, Australia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=libplacebo
-VERSION=${VERSION:-3.120.3}
+VERSION=${VERSION:-6.338.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -72,6 +70,7 @@ cd $TMP
rm -rf $PRGNAM-v$VERSION
tar xvf $CWD/$PRGNAM-v$VERSION.tar.gz
cd $PRGNAM-v$VERSION
+patch -p0 < $CWD/use_meson-0.59.4.diff
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -88,8 +87,8 @@ else
RELEASE=plain
fi
-# Use an older epoxy version.
-sed -i 's/1.4.0/1.3.1/' src/meson.build
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -99,6 +98,7 @@ meson \
-Dstrip=$NDEBUG \
-Db_ndebug=$NDEBUG \
-Dbuildtype=$RELEASE \
+ -Ddemos=false \
build
"${NINJA:=ninja}" -C build